[sane-devel] Canon Lide20 problem - scanimage works, all others not working

PhobosK phobosk at mail.kbfx.org
Thu Mar 15 12:54:42 CET 2007

Hi all,
I have a Gentoo system and:
scanimage (sane-backends) 1.0.18; backend version 1.0.18
libusb 0.1.12
KDE 3.5.6
gcc (GCC) 3.4.6 (Gentoo 3.4.6-r2, ssp-3.4.6-1.0, pie-8.7.10)
scanner Canon Lide20

xsane, kooka and xscanimage stopped working with my scanner.
Unfortunately I cannot tell the exact reason why (an update to a lib, kernel etc.)

In fact scanimage works Ok but any other GUI frontend (xscanimage, xsane and kooka) doesn't work. xscanimage/xsane/kooka take several minutes and finish normally but hardware doesn't work at all and the result image is whole black and no errors (all needed debug flags set) given in console. 

I have tried:
1. To install old sane/xsane versions but none of them worked.
2. To use the above mentioned not working applications with a fresh start (deleting ~/.sane folder) with no effect.
3. To use the above mentioned not working applications as root - still no effect.

I have no "/usr/lib/sane" entry in ld.so.conf
I tried to have only one entry in /etc/sane.d/dll.conf for plustek but that does not help either.

If you need debug from scanimage and xsane for comparison just tell me.... I have looked at them but found nothing interesting except the missing lines for the MOTOR hardware behaviour...

PhobosK - A KBFX Team Member
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20070315/d45de3b6/attachment.htm

More information about the sane-devel mailing list