[sane-devel] Problem with alioth, additional problem with Lexmark X1170

Stéphane VOLTZ stef.dev at free.fr
Sun May 6 05:46:17 UTC 2007

Le samedi 5 mai 2007, Stefan Göttsche a écrit :
> Hi, I'm unsure if I am correct in posting this here.
> To introduce myself shortly, I am a german living in France,
> and I run openSUSE Linux 10.2, KDE 3.5.6.
> First of all, I've got a problem with the sane-project website, or more
> precisely alioth.  I wanted to report a bug, but a button to report bugs
> was nowhere to be seen. I figured that I have to create an account for just
> this one bug, and proceeded to registration. After quite a bit of
> information about me I finally got the email, clicked, and got the error
> message : "Alioth cannot connect to database" on an otherwise blank page.
> Now, I should register that as a website bug, but since I need to log in
> for the bugtracker I simply can't. I don't know if the server is down for
> maintenance, or something else along that line, I'll try again later.
> Second, the reason for my bug report :
> I own a Lexmark X1170 printer/scanner, and the printer works just fine.
> I used SANE to install the scanner, and upon testing, something goes
> majorly wrong :
> Instead of moving the scanning unit towards the glass window it starts
> moving the unit -in the other direction- ! Since there is a point the
> mechanic inside can't overcome, the motor starts to whine under torture,
> and after two or three seconds the scanner just stops.
> The scanner is correctly detected by sane using scanimage to list the
> scanners.
> I have tried and experienced this problem with Xsane, scanimage and Kooka,
> which exhausts all the frontends I have. I conclude that this must be a
> problem inside Sane or with my hardware, although the last time I scanned
> under Windows it functioned normally. I will check that out though as soon
> as I have some time to boot up windows XP.
> I have not tried to further deepen the diagnostic, as the scanner does this
> at every attempt to scan or preview, and the unit starts smelling a bit of
> overheated electronics when trying. I don't want to destroy the scanner
> motor.
> Any advice on this would be very appreciated, as it is the only (rare) task
> on the computer left for which I have to boot Win XP now. I don't like to
> boot it anymore, and until now I am very happy with OpenSuse :)
> Thanks
> Stefan


	there are at least 2 variant of X11xx models. The regular lexmark backend 
only handles one. The experimental now fully support both (and color scans 
for X1xx models). You can either get the code from the cvs/experimental area 
or get a full patched source archive at 
http://stef.dev.free.fr/sane/lexmark .
	Once this version will be regression tested on A920, I'm considering removing 
all debugging code and moving it to the regular cvs.


More information about the sane-devel mailing list