[sane-devel] Backends configure can't find libusb

Tom Garvin tomgarvin at amyskitchen.net
Thu May 31 17:44:27 UTC 2007

I'm installing on nanoBSD (a variant of FreeBSD).  The
configure/make/install process for libusb seems to go just fine.  I see
/usr/lib/include/usb.h and it's the same file as in the libusb package.
When I run the backends configure, I get:

checking usb.h usability... no
checking usb.h presence... no
checking for usb.h... no
*** Warning: sane-backends will be built without libusb support.  There
*** be valid reasons to do so, e.g. if you don't use USB scanners or on
*** platforms without libusb support but generally this means that you
*** can't use USB devices with SANE. The most probable cause is that
*** the libusb header file usb.h is not installed. If you use Linux
*** you may need a package called 'libusb-dev', 'libusb-devel' or

I've tried 'configure --includedir=/usr/local/include' and 'gmake
-I/usr/local/include' to no avail.  Not an expert in this process, so
I'm grasping at straws.

More information about the sane-devel mailing list