[sane-devel] Backends configure can't find libusb

m. allan noah kitno455 at gmail.com
Thu May 31 18:54:32 UTC 2007

i'm not sure, but that 'lib' in the location of usb.h looks odd to me.
i doubt that sane's configure is looking for it there. try moving it
to /usr/include (or rebuild the libusb package to put it there), or
perhaps set CPPFLAGS env var before you build.


On 5/31/07, Tom Garvin <tomgarvin at amyskitchen.net> wrote:
> I'm installing on nanoBSD (a variant of FreeBSD).  The
> configure/make/install process for libusb seems to go just fine.  I see
> /usr/lib/include/usb.h and it's the same file as in the libusb package.
> When I run the backends configure, I get:
> [...]
> checking usb.h usability... no
> checking usb.h presence... no
> checking for usb.h... no
> [...]
> *** Warning: sane-backends will be built without libusb support.  There
> may
> *** be valid reasons to do so, e.g. if you don't use USB scanners or on
> *** platforms without libusb support but generally this means that you
> *** can't use USB devices with SANE. The most probable cause is that
> *** the libusb header file usb.h is not installed. If you use Linux
> *** you may need a package called 'libusb-dev', 'libusb-devel' or
> similar.
> [...]
> I've tried 'configure --includedir=/usr/local/include' and 'gmake
> -I/usr/local/include' to no avail.  Not an expert in this process, so
> I'm grasping at straws.
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

"The truth is an offense, but not a sin"

More information about the sane-devel mailing list