[sane-devel] Scanning stops immedaitely in Feisty Fawn

Hernádi Zoltán dying_sun at freemail.hu
Tue Oct 2 15:34:04 UTC 2007


My scanner works well in Ubuntu 6.06 Dapper Drake, but it has some
issues in Ubuntu 7.04 Feisty Fawn. Although the 'microtek2' driver is
unmaintained now, I could compile the kernel modules and insert them
into the kernel in both Ubuntu verions.

In Ubuntu 7.04 Feisty Fawn, the scanner starts scanning by setting the
position of its lamp to the top - making some sound of operating - and
immediately stops there doing nothing. I tried 'scanimage' to see what's
there and I got the following output:

# SANE data follows
611 842

That's all, no error messages. If I start 'scanimage' again, I get
"scanimage: sane_start: Error during device I/O" error, but I can safely
'rmmod onscsi', switch off the scanner, switch it on again, 'insmod
onscsi' and start 'scanimage' again to get the 4 lines above for the
second time. :D I even tried to run 'scanimage' as root user without any
more success. In Ubuntu 6.06 Dapper Drake, the scanner works completely,
without difficulties (I checked it today using a Live CD).

Scanner model: Microtek Phantom 330
Scanner port: parallel
Parallel port BIOS setting: EPP 1.7 (I also changed some other options
without any more success.)
SANE driver: microtek2 and ppscsi-beta2 from
'scanimage -L' shows: device `microtek2:/dev/sg4' is a Microtek
ScanMaker 336 / ScanMaker V310 flatbed scanner
Feisty Fawn kernel version: 2.6.20-16-generic
Feisty Fawn SANE version: 1.0.18; backend version 1.0.18

I don't know the exact Dapper Drake SANE version, but the Feisty version
should not be earlier - I can certainly check it, if needed.

Notice: I could compile the kernel modules for Dapper Drake by running
the 'make' command on the original content of
ppscsi-beta2-20060424.tar.gz, but I had to modify the source code in
order to compile the modules for Feisty Fawn. I have changed 3 lines in
2 files, here the differences are the following:

$ diff ppscsi.h_original ppscsi.h
< #include <linux/config.h>
> #include <linux/autoconf.h>

$ diff ppscsi.c_original ppscsi.c
< static void ppsc_tq_int (void *data)
> static void ppsc_tq_int (struct work_struct *data)
<               INIT_WORK(&pha->wq, ppsc_tq_int, pha);
>               INIT_WORK (&pha->wq, ppsc_tq_int);

After these changes I could succesfully compile the kernel modules for
Feisty Fawn by running the 'make' command.

I insert the modules into the kernel by the following commands in both
Ubuntu versions:
modprobe sg
insmod ppscsi.ko
insmod onscsi.ko

There are no error messages shown when inserting the modules.

Please tell me, if there is anything I can do to get the scanner working
well in Feisty Fawn?


More information about the sane-devel mailing list