[sane-devel] Scanner Epson recognize only on root

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Wed Jan 9 00:18:24 UTC 2008

Guillaume <bou.gui at wanadoo.fr> writes:

> Hi everyone.
> Please forgive my very poor english, i'm a french user of Sane...
> Since the 4th of January, my Epson Perfection 610 USB is no more 
> recognize by Sane (but is still recognize by lsusb) ; he worked very 
> fine before.
> The only way i found to make it recognizable, it's to run Sane on root, 
> despite of the warning.
> The 01/04, there was an update of libsane ; perhap's a clue ?

Sounds like a permission problem to me.  Check what GROUP is used in
your /etc/udev/libsane.rules and whether you are a member of it.  On
my Debian system, the entry looks like:

  # Epson Perfection 610
  SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="0103", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

so you would need to be in the 'scanner' group in order to access the
device.  You can check what groups you are in with the


command.  To add yourself to the scanner group:

  sudo adduser $USER scanner

> Can someone help me ?
> I worked on Ubuntu Hardy.

Hope this helps,
Olaf Meeuwissen             FLOSS Engineer -- EPSON AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/

More information about the sane-devel mailing list