[sane-devel] XSane not showing full list of resolutions for Epson V500

cda-kfmg at kaspop.com cda-kfmg at kaspop.com
Thu Jul 10 07:36:43 UTC 2008

> The bug is caused by an infelicity in the saneopts.h header file.
> exactly the same.  With Image Scan! I redefine the latter to
> "x-resolution" so things work as expected.
> If you really need xsane, you can fix this by recompiling with a
> fixed saneopts.h and I guess I should get that file fixed
> upstream ;-)

I'm not sure if I should have tried this but I made the change you
mentioned above to SANE_NAME_SCAN_X_RESOLUTION
(sane-backends-1.0.19) and recompiled sane, iscan and xsane.

The result was that xsane picked up a variety of resultions for
both x and y but the list of resolutions for both did not match.

Also, although xsane would preview in binary mode it issued an
error dialogue box when I tried to preview in color. It then hung.

I've attached a debug log.

Thanks for your time.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug.log.bz2
Type: application/octet-stream
Size: 7309 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20080710/fe63ea45/attachment-0001.obj 

More information about the sane-devel mailing list