[sane-devel] XSane not showing full list of resolutions for Epson V500

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Tue Jul 15 07:59:09 UTC 2008

Sorry for not getting back earlier.  "Real Work" got in the way.

cda-kfmg at kaspop.com writes:

>> The bug is caused by an infelicity in the saneopts.h header file.
>> exactly the same.  With Image Scan! I redefine the latter to
>> "x-resolution" so things work as expected.
>> If you really need xsane, you can fix this by recompiling with a
>> fixed saneopts.h and I guess I should get that file fixed
>> upstream ;-)
> I'm not sure if I should have tried this but I made the change you
> mentioned above to SANE_NAME_SCAN_X_RESOLUTION
> (sane-backends-1.0.19) and recompiled sane, iscan and xsane.
> The result was that xsane picked up a variety of resultions for
> both x and y but the list of resolutions for both did not match.

That's OK.  The lists of horizontal and vertical resolutions are not
the same and the latter has more entries.

> Also, although xsane would preview in binary mode it issued an
> error dialogue box when I tried to preview in color. It then hung.
> I've attached a debug log.

Apparently, something went wrong when initiating the scan but from the
log I can't really tell what.  Please try previewing in colour with
scanimage as follows:

  SANE_DEBUG_EPKOWA=127 SANE_DEBUG_SANEI_USB=127 scanimage --mode Color --resolution=200 --preview=yes > image.pnm 2> debug.log

(all in one command).  This may create a boat-load of debug info so
please compress it and send it *off-list*.

Hope this helps,
Olaf Meeuwissen                   FLOSS Engineer -- AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/

More information about the sane-devel mailing list