[sane-devel] Epson SX515W - Epson PID flatbed scanner - FAIL Error: Error during device I/O

John McCreesh jpmcc at users.sf.net
Tue Dec 29 17:36:29 UTC 2009

On Tue, December 29, 2009 2:12 pm, Alessandro Zummo wrote:
> On Tue, 29 Dec 2009 10:32:53 -0000 (GMT)
> "John McCreesh" <jpmcc at users.sf.net> wrote:
>> I'm new to git - so, I did:
>> $ git clone http://git.debian.org/git/sane/sane-backends.git
>  Do you have the old libraries still installed?
>  Did you tried via usb?

Removed libsane with synaptic.
sudo apt-get install libusb-dev
make clean
sudo make install

scanimage -T
Success (over WiFi)!

One little bug (?) I spotted:
$ scanimage --mode Color --progress > temp.pnm
scanimage: unrecognized option '--progress'
$ scanimage --mode Color -p > temp.pnm
works ok

When I removed libsane with synaptic I lost hpijs, hplip, sane-utils, and
xsane. I grabbed xsane-0.997.tar.gz from
http://www.xsane.org/cgi-bin/sitexplorer.cgi?/download/, sudo apt-get
install libgtk2.0-dev the the usual /.configure & make sudo & make
install. After rm -rf ~/.sane/xsane/* xsane worked too (also over WiFi).

So Alessandro many thanks for your help, and I hope these notes will help
other people Googling with the same problem


More information about the sane-devel mailing list