[sane-devel] /usr/bin/ld: cannot find -lsane

rohit bal rohitsharma36 at hotmail.com
Thu Feb 26 12:22:28 UTC 2009

Hi Dieter,

Thanks for the info.

I did some changes finally my application is working fine with all the devices.

Dieter Please let me know one thing I want to know which SANE Backend is installed in my machine & also I want to know its path.

I also want to know where is the libsane path and other sane dependent binaries path which is allowing my scanner to work.

Because I was facing issues with RPM's Allan
and simon told me to load Fedora 10.0 which comes with sane-backends-devel-1.0.19-12.fc10.i386 
and HPLIPs but when there was Sane.h & Saneopts.h files missing in my machine so I copyied the same from another machine & dumped in usr\local\include.

Then again my application was not able to find LIBSANE so what I did I compiled the sane-backends-devel-1.0.19-12 TAR BALL and then Uninstalled 2-3 times finally when I run my application every scanners started working this was very confusing.

so I want to know the paths where sane comes default in machine. This will help me in detecting that what came defaualt with Fedora 10.0 and what I installed.


From: rohitsharma36 at hotmail.com
To: sane-devel at lists.alioth.debian.org
Subject: /usr/bin/ld: cannot find -lsane
Date: Tue, 24 Feb 2009 10:19:04 +0000


When I compile my code in Fedora 10.0 I get this error , even though ld is present in /usr/bin still I get the same error message...


Discover your phone style & WIN a Windows Mobile phone. Your style! Try it now!
For the freshest Indian Jobs Visit MSN Jobs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20090226/d55b466c/attachment.htm 

More information about the sane-devel mailing list