[sane-devel] Segmentation Fault

Chris Bagwell chris at cnpbagwell.com
Wed Mar 4 01:31:17 UTC 2009

2009/3/3 Russell King <rjkfsm at gmail.com>

> Well, I tried that and xsane now complains that it needs sane-backends
> 1.0.0 or higher.
> To get here, I had to unmerge sane-backends, sane-frontends and xsane, then
> to keep portage from bashing them, I masked them. I then downloaded the
> source for sane-backends and compiled it. That went fine and when I tried
> the same with xsane, I get:
> ERROR: SANE-1.0.0 or newer is needed for compiling xsane
>      - if you installed SANE as rpm make sure you also included
>        sane-devel
I just did some limited testing with current CVS and xsane- 0.996 and had
success.  Note: I found an additional typo in sane-config and just submitted
a fix to CVS.  You'll want to update again.

Your error message above is because xsane can not find the "sane-config" of
your CVS sane-backends.  Step I did are similar to following:

cd sane-backend
./configure --prefix=/usr/local/sane
make; make install

export PATH=/usr/local/sane/bin:$PATH
cd /path/to/src/xsane-0.996
cd src
vi xsane-backend-gtk.c
<comment out all of if(SANE_CAPS_ALWAYS_SETTABLE) at lines 2615-2618 as its
not documented by SANE1 API and not in current CVS... It was in sane-1.0.19
for what ever reasons but only used by qcam and v4l  backends. I'm sure
you'll not notice reduced functionality.>
cd ..
./configure --prefix=/usr/local/xsane LDFLAGS=-L/usr/local/sane/lib
make; make install

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20090303/c081e1d2/attachment.htm 

More information about the sane-devel mailing list