[sane-devel] the samsung scx-4200 works with the xerox mfp driver

m. allan noah kitno455 at gmail.com
Sun Nov 29 12:17:18 UTC 2009

try running scanimage -L as root. That should bypass any permissions issues.


On Sat, Nov 28, 2009 at 8:43 PM, Maks <maksimalac at gmail.com> wrote:
> I need some advice regarding the installation of samsung scx-4200
> scanner in ubuntu 9.10. I started to use ubuntu few months ago, after
> years of using win xp. Now I have ubuntu 9.10 and win xp installed on my
> machine (dual boot), but I'm anxious to learn about ubuntu as much as I
> can, so I can discard windows entirely.
> My problem is that I can't get my scanner working in ubuntu. I've added
>  #scx4200
>  usb 0x04e8 0x341b
> to /etc/sane.d/xerox_mfp.conf, but now I'm stuck.
> It seems that ubuntu detects scanner when I type "sane-find-scanner":
> # sane-find-scanner will now attempt to detect your scanner. If the
>  # result is different from what you expected, first make sure your
>  # scanner is powered up and properly connected to your computer.
>  # No SCSI scanners found. If you expected something different, make
> sure that
>  # you have loaded a kernel SCSI driver for your SCSI adapter.
> found USB scanner (vendor=0x04e8 [Samsung], product=0x341b [SCX-4200
> Series]) at libusb:001:002
>  # Your USB scanner was (probably) detected. It may or may not be
> supported by
>  # SANE. Try scanimage -L and read the backend's manpage.
>  # Not checking for parallel port scanners.
>  # Most Scanners connected to the parallel port or other proprietary
> ports
>  # can't be detected by this program.
>  The trouble is (to my knowledge) that I have Leadtek WinFast TV tuner
> card installed. So when I type "scanimage -L", I get:
> device `v4l:/dev/video0' is a Noname BT878 video (Leadtek WinFast 20
> virtual device.
> When I run XSane image scanner, I get the same result - my scanner is
> Leadtek WinFast device.
> I would really appreciate some help on this matter, if possible
> step-by-step advice on what I should do. Google offers a lot of advices
> on how to do this thing using Samsung unified driver, but Michael wrote
> that samsung's proprietary driver performs ugly hacks, and I believe
> him. So...
> Thanks,
> Max
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org

"The truth is an offense, but not a sin"

More information about the sane-devel mailing list