[sane-devel] Slow scanner & timeout

Erik Lotspeich erik at lotspeich.org
Thu Apr 15 13:13:29 UTC 2010

Hi Allan,

Thanks for your response -- directing me to the sane source was a big
help.  I was worried I'd have to get into the USB driver.

I poked around in the source for a bit and discovered an environment
variable SANE_HP_RDREDO.  I set this to 200 and that allowed sane to
wait much longer -- I can get scans now with the XPA.

When I used to use scanner with XPA with SCSI, it might take 1 minute
for the lamp to warm up before the first scan and a much shorter time
after that.  Now I'm waiting nearly 5 minutes... but that's not a
problem with sane, I'm sure.  Maybe my 9-year old machine is showing
signs of age.

OT: When I bought this scanner, I thought that it would be a nice
mid-range model.  When scanning slides, it's obvious it has a limited
color/contrast range; I see banding and digital noise as well.  For
negatives, it's worthless.



m. allan noah wrote:
> The HP 6x00 scanjets use ancient usb 1.0 (not even 1.1) IIRC. I had
> lots of problems with this scanner on USB on every machine I tried.
> Eventually I gave up and scrapped it. If you want to try and fix it, I
> would get the source of sane-backends 1.0.20, and see if you can add
> any calls to sanei_usb_set_timeout to the hp backend.
> allan
> On Wed, Apr 14, 2010 at 9:59 AM, Erik Lotspeich <erik at lotspeich.org> wrote:
>> Hi,
>> I have an HP ScanJet 6300c that I've been using successfully with sane
>> for some time now.
>> I have a problem when I use the XPA.  With the XPA, the scanner takes a
>> LONG time (it waits for the XPA lamp to warm up) to handle scan
>> requests.  The problem is that sane timeouts with an I/O error before
>> the scanner is ready.  When the scanner is ready (you can hear it
>> attempt to start the scan), sane is no longer listening.
>> This scanner has both SCSI & USB interfaces.  I've used this scanner
>> with XPA & sane many years ago with the SCSI interface -- it worked with
>> SCSI.  I'm using the USB interface now.
>> I did some searching on the Internet and I didn't see any definite
>> answer.  I don't know if this is a sane issue or a USB one.  dmesg and
>> /var/log/messages yield no error messages or warnings.
>> I use OpenSUSE 11.1 with the following packages:
>> # rpm -qa |grep sane
>> sane-frontends-1.0.14-302.35
>> xsane-0.995-131.35
>> sane-backends-autoconfig-1.0.19-99.1
>> sane-backends-1.0.19-99.1
>> Any help would be greatly appreciated.
>> Regards,
>> Erik
>> --
>> sane-devel mailing list: sane-devel at lists.alioth.debian.org
>> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
>> Unsubscribe: Send mail with subject "unsubscribe your_password"
>>             to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list