[sane-devel] ADF problem on HP ScanJet 8270 (ERR: Scanner cover is open)

Valentine Christian valentine.christian at gmail.com
Tue Jul 6 04:27:07 UTC 2010

I have essentially the same problem on my HP 8250 scanners.  The only
effective workaround is to power down the scanner, connect to an XP (or
other M$ product with HP drivers installed), and start up the wizard.  It
manages to take the scanner out of the error 15 state, and I can move along
until the next paper jam or other error condition.

On Mon, Jul 5, 2010 at 10:07 PM, Marius Ruth <marius.ruth at gmail.com> wrote:

> Hi list,
> I have a very annoying issue with the HP ScanJet 8270 I bought a few days
> ago.
> Although normal scanning works great when I try to use the feeder
> (ADF) I get this error:
> "Scanner cover is open"
> Obviously, the scanner cover is NOT open. I search everywhere for a
> solution but there seems to be none that will work.
> Scanner is running properly in Diagnostic mode.
> I've also tried what this person suggested with no luck:
> http://lists.alioth.debian.org/pipermail/sane-devel/2005-December/015797.html
> I'm running CentOS release 5.5, kernel 2.6.18-194.el5.
> *sane* packages from RPM will not detect the scanner so I compiled it
> from source code.
> I've tested with the latest stable versions:
> sane-backends-1.0.21,
> sane-frontends-1.0.14,
> xsane-0.996
> and with the latest development release:
> sane-backends-git20100705.tar.gz
> sane-frontends-git20100705.tar.gz
> The error message I get in sane for both is: "Scanner cover is open"
> The error I see on the HP scanner LCD is "Error 15"
> Scanner is connected via USB.
> I've tried with xscan, scanimage -b, scanadf (all with same results,
> the issue is definitely with sane and not the frontends.. i think)
> I've also tried to play with the sourcecode of the "avision" lib
> quickly commenting the "cover open status" checks and calls, still no
> luck. I'll try to debug the code tomorrow but until then i'd really
> like to know if anybody over here can help me out please.
> My theory is that the adf is not properly initialized and this is why
> the feeder scanning fails. I can hear a noise comming from the feeder
> when I issue the command to scan but it dies with the "scanner cover
> is open" error message after ~5 seconds.
> I've uploaded a full debug log here: http://pastebin.com/HXzhMPsu
> Relevant snapshot from debug run follows:
> [avision] avision_usb_status: Needs to request sense!
> [avision] sense_handler:
> [avision] sense_handler: data:
> [avision]   [0] 11110000b 360o 240d f0x
> [avision]   [1] 00000000b   0o   0d  0x
> [avision]   [2] 00000011b   3o   3d  3x
> [avision]   [3] 00000000b   0o   0d  0x
> [avision]   [4] 00000000b   0o   0d  0x
> [avision]   [5] 00000000b   0o   0d  0x
> [avision]   [6] 00000000b   0o   0d  0x
> [avision]   [7] 00001110b  16o  14d  ex
> [avision]   [8] 00000000b   0o   0d  0x
> [avision]   [9] 00000000b   0o   0d  0x
> [avision]   [10] 00000000b   0o   0d  0x
> [avision]   [11] 00000000b   0o   0d  0x
> [avision]   [12] 10000000b 200o 128d 80x
> [avision]   [13] 00000010b   2o   2d  2x
> [avision]   [14] 00000000b   0o   0d  0x
> [avision]   [15] 00000000b   0o   0d  0x
> [avision]   [16] 00000000b   0o   0d  0x
> [avision]   [17] 00000000b   0o   0d  0x
> [avision]   [18] 00000000b   0o   0d  0x
> [avision]   [19] 00000000b   0o   0d  0x
> [avision]   [20] 00000000b   0o   0d  0x
> [avision]   [21] 00000000b   0o   0d  0x
> [avision] sense_handler: sense code: MEDIUM ERROR (mostly ADF)
> [avision] sense_handler: scan has not yet been completed
> [avision] sense_handler: correct logical length
> [avision] sense_handler: sense code: ADF cover open
> [avision] reader_process: start_scan faild: Scanner cover is open
> [avision] sane_read: got 0 bytes, err: 0 Success
> [avision] do_eof:
> [avision] do_eof: returning 8
> [avision] sane_cancel:
> Please advise,
> Thanks,
> M
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100706/7e75445d/attachment-0001.htm>

More information about the sane-devel mailing list