[sane-devel] scanimage 1.0.20 hangs on Solaris 10/SPARC (pixma backend)

Patrick Simmons linuxrocks123 at netscape.net
Wed May 12 07:13:33 UTC 2010

Hey, I'm back.

I tried the LIBUSB_DEBUG thing and got the following:

psimmons at SimmonsSystems:~$ export SUN_LIBUSB_DEBUG=3
psimmons at SimmonsSystems:~$ scanimage --format=tiff
usb debug level is 3
reading entry .
reading entry ..
reading entry libusbugen.so
did not load /usr/sfw/lib/libusb_plugins:libusbugen.so
reading entry libusbugen.so.1
reading .so file /usr/sfw/lib/libusb_plugins:libusbugen.so.1
Path is /usr/sfw/lib/libusb_plugins/libusbugen.so.1
load_plugin: modname is libusbugen.so.1
loading:libusbugen.so.1 pindex:0
usb_open: pindex = 0
usb_open: pindex = 0
usb_open: pindex = 0

Any clues what could be wrong?  Please CC me as I am not on the list.

Thanks for any help,

Chris Bagwell wrote:
> The easy thing I can suggest is to try compiling with
> "--enable-pthread".  I recall a past discussion related to libusb and
> that sometimes causing it to work better.
> If that doesn't fix things for you then your going to have to debug
> this yourself.  I do not think there are any active Solaris developers
> on the mailing list.  See "man san", "man sane-usb", and "man
> sane-<backend>" (replace<backend>  with real name) for information on
> what environment variables you can see to enable debug output.
> Chris
> On Sun, Feb 28, 2010 at 2:13 AM, Patrick Simmons
> <linuxrocks123 at netscape.net>  wrote:
>> Hello all,
>> I'm trying to get SANE 1.0.20 working with a Canon MP210 USB scanner on
>> Solaris/SPARC.  I'm using the latest Solaris 10 build.  However, I can't get
>> it to scan.  When I do scanimage -L, my scanner is shown correctly after a
>> moderately long delay, but scanimage just hangs forever when I try to use it
>> to scan.  scanimage will also hang forever when run with the --help option,
>> after printing out the help text.  It's as if it's trying to print the
>> scanner name but ran into trouble.
>> I've followed README.Solaris to the letter, except that I also changed an
>> include path in the Makefile from "-I/usr/local/include" to "-I/usr/include"
>> because the md5.h in /usr/local/include won't compile on my machine for some
>> reason.  I experience the same behavior with the latest GIT snapshot.  The
>> same behavior happens whether I am root or a user.  I have verified that the
>> scanimage works with SANE 1.0.20 on Linux/AMD64; in addition, I until
>> recently ran Linux/SPARC on the Solaris 10 machine.  scanimage worked there
>> with a development snapshot of SANE calling itself "SANE 1.1.0".
>> Does anyone know what could be wrong?
>> Thanks,
>> --Patrick

More information about the sane-devel mailing list