[sane-devel] Detect scan button on ScanSnap S1500 (sane-fujitsu backend)

Mikael Nordenberg mikael at ikanos.se
Fri Nov 5 20:52:12 UTC 2010

Hi list.

I've tried really hard to find information about how to detect if the button
on my scanner is pressed.
I've got a ScanSnap S1500, which is supported by the fujitsu backend, and
works as expected using for example scanimage.

The scanner itself only has one backlit button titled "scan". If I press it,
it starts to blink for a couple of seconds and then goes back to normal
(which is constant lit).

If I type "scanimage --help" I'm presented with numerous sensor options,
including the following:
    --scan[=(yes|no)] [no] [hardware]
        Scan button

Typing "scanimage --scan" results in:
scanimage: unrecognized option '--scan'

(None of the other sensor options is recognised either.)

I've tried to access the scanner via saned using the network protocol, but
the scan-option (#83) always responds false, even if I press and hold the
scan button.

Is this model not supported when detecting buttons, or am I doing something
completely wrong?

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20101105/2f5626f3/attachment.htm>

More information about the sane-devel mailing list