[sane-devel] Hello - new scanner Canon canoscan n1240U doesn't work

Gernot Hassenpflug aikishugyo at gmail.com
Sun Sep 26 23:10:29 UTC 2010

On Mon, Sep 27, 2010 at 3:20 AM, David Kremer <ooh2iej7ae at gmail.com> wrote:
>> Hi David,
>> some questions:
>> 1.) did you try sane-find-scanner as root or as normal user?
>> 2.) did you try scanimage as root or as normal user?
>> 3.) did you (as suggested) try scanimage -L?
>> 4.) What is your operating system?
> Hello, yes, I tried as root and normal user, it didn't change the result. I
> tried both scanimage alone and scanimage -L, it didn't make a difference.
> My operating system is archlinux, kernel 2.6.35, sane is version 1.0.21.

Hi, that certainly is strange since I used the N1240U for several
years with SANE and it always worked beautifully. What happens if you
set the various DEBUG environment variables for sane, sane-plustek,
sane-usb and so forth (check man pages for these items), to see where
the problem starts to occur (for example, does the plustek backend
ever get called?


More information about the sane-devel mailing list