[sane-devel] Canon LiDE 200 scanning fails with backends from PPA

Martin Ueding list at martin-ueding.de
Mon Apr 25 12:47:35 UTC 2011

Hi Everyone,

I tried to use the new sane-backend from the Robert Ancell PPA as
described in the [ubuntuforums

According to that post, I should be able to scan with my Canon LiDE 200
using the `sudo simple-scan` command.

The first attempt to scan after attaching the scanner to the computer
(Apple iMac, Intel Core 2 Duo, Ubuntu 10.10 32-Bit) yields some sounds
from the motor of the scanner, but the scanner head barely moves. The
terminal I launched simple-scan from displays the following message:

	** (simple-scan:4209): WARNING **: Unable to start device: Error during
device I/O

When I started another scan, it would do nothing and just block the
program for a while.

Today, I tried the same on another computer (Asus Eee, Intel Atom,
Ubuntu 10.10 32-Bit), and I managed to scan one single page without any
errors. After that, simple-scan showed the message.

I attached the `simple-scan -d` output of a first and a subsequent scan.
If there is anything else I can do to diagnose the problem, please let
me know.

How can I get my scanner to work on either computer?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug-1.txt.gz
Type: application/x-gzip
Size: 2578 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110425/79c460de/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug-2.txt.gz
Type: application/x-gzip
Size: 2457 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110425/79c460de/attachment-0001.bin>

More information about the sane-devel mailing list