[sane-devel] Canon LiDE 200 scanning fails with backends from PPA

Kelly Price strredwolf at gmail.com
Mon Apr 25 14:24:06 UTC 2011

Is USB Autosuspend on in the kernel?- I had the same problem. Turning autosuspend off fixed it on the LiDE 30's. I won't be surprised if these scanners don't like it.

Sent from my iPhone

On Apr 25, 2011, at 8:47 AM, Martin Ueding <list at martin-ueding.de> wrote:

> Hi Everyone,
> I tried to use the new sane-backend from the Robert Ancell PPA as
> described in the [ubuntuforums
> post](http://ubuntuforums.org/showpost.php?p=10526638&postcount=31).
> According to that post, I should be able to scan with my Canon LiDE 200
> using the `sudo simple-scan` command.
> The first attempt to scan after attaching the scanner to the computer
> (Apple iMac, Intel Core 2 Duo, Ubuntu 10.10 32-Bit) yields some sounds
> from the motor of the scanner, but the scanner head barely moves. The
> terminal I launched simple-scan from displays the following message:
>    ** (simple-scan:4209): WARNING **: Unable to start device: Error during
> device I/O
> When I started another scan, it would do nothing and just block the
> program for a while.
> Today, I tried the same on another computer (Asus Eee, Intel Atom,
> Ubuntu 10.10 32-Bit), and I managed to scan one single page without any
> errors. After that, simple-scan showed the message.
> I attached the `simple-scan -d` output of a first and a subsequent scan.
> If there is anything else I can do to diagnose the problem, please let
> me know.
> How can I get my scanner to work on either computer?
> Regards,
> Martin
> <debug-1.txt.gz>
> <debug-2.txt.gz>
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list