[sane-devel] Status of Avision

Jeroen Eeuwes jeroeneeuwes at gmail.com
Fri Jan 7 11:16:42 UTC 2011

Hi Mike,

> According you your last post, you ran:
> $ scanimage -l 5mm -t 5mm -x 15mm -y 15mm 2> scanner-name.log > scanner-name.png

I just did a "git clone" of the sane-backends repository (AFAICR I did
that in 2009 too). I ran this command:

sudo SANE_DEBUG_AVISION=7 /usr/local/bin/scanimage -l 5mm -t 5mm -x
15mm -y 15mm 2> AV220G-5-15.log > AV220G-5-15.png

That worked OK. Actually this is an improvement but this didn't work
right in 2009 :)

> Another thing to try is changing the size of the scan area, since a small
> area scans perfectly, it would be interesting to know what the boundaries
> are.

I increased the size of the -x and -y parameters. That's OK until I
use 202 for both the x or y parameter. The results in behaviour are a
bit different than last time. Now the units sits idle for a while, it
tries to 'eject' a page (even though the page had already gone through
the system), it is idle again and then it beeps very loudly (until
turned off).
If I turn the scanner off scanimage will end without generating a
valid png file. It does the same if I put multiple pages in the
scanner. It will go through page 1 and 2. Then it will start to pull
page 3 in the scanner, but it stop once it is in and then the unit
starts beeping. Note, this is all without the -b option.

I tried -x 200mm -y 250mm and vice versa but the results were the same.

The -x 200mm and -y 200mm work, but I get only about 2/3 of the page.
That matches the command of course, 200mm is about 2/3 of the length
of an A4.

Attached is the log from this (failed) command:

sudo SANE_DEBUG_AVISION=7 /usr/local/bin/scanimage -l 5mm -t 5mm -x
200mm -y 250mm 2> AV220G-5-250.log > AV220G-5-250.png

I tried with -x 20mm and -y 300mm. That worked OK! I had the entire
length of the page, but only a small bit. I increased the -x (in large
steps) until it stopped working. At 150mm it said "Segmentation
fault". After a bit of trying I found that -x 120mm -y 300mm works OK,
above 120 it will not work. Sometimes it will say "Segmentation fault"
immediately, sometimes the unit will eject a non-existing page and
starts beeping.

I did not get the -b or --batch command to work at all. That gives the
same faulty result: 1 page 'scanned', 1 page 'ejected', the third page
stuck and a loud beep until turned off.

If scanimage works OK I'll get a readable image file. If it doesn't
then I have a file which can't be read. GIMP just says "not a valid
file", GPicView says "Premature end-of-file encountered". Geeqie will
show the file, but the image is only shown a bit (depending on the
size of the file: sometimes half, sometimes less).

What can I try next? ;)

Best regards,
Jeroen Eeuwes
-------------- next part --------------
A non-text attachment was scrubbed...
Name: AV220G-250mm.zip
Type: application/zip
Size: 6533 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110107/7bfce796/attachment.zip>

More information about the sane-devel mailing list