[sane-devel] CanoScan 9000F code compilation

Al Bogner sane at ml093.pinguin.uni.cc
Sun Jul 3 11:28:17 UTC 2011

Am So, 03 Jul 2011 09:54:31 CEST schrieb Stefan Polakowski:

> Al,
> no success here under Ubuntu 10.10, also after waiting almost one
> day... I compiled Gernot's sane backend and added the udev rule as
> well. sane-find-scanner does find the scanner, but scanimage -L does
> not find it.

I tried it with Natty (11.04). First I thought it is necessary to
reboot, but with another machine, I had to wait only a few hours and
the scanner was recognized then, without doing anything. I was shopping
in the meantime.

> I tried as root,

Did you install the driver as root or with sudo? Try as root.

I mean
sudo passwd root
su -

> and also changed the access rights to the USB
> device /dev/bus/usb/002/00x (I know it's not the right way, just
> experimental).
> sane-find-scanner is checking various device files
> like /dev/usb/scanner0..15 and /dev/usbscanner0..15 (as shown when
> using the -v option), but all without success. Finally it prints:
> found USB scanner (vendor=0x04a9 [Canon], product=0x1908 [CanoScan])
> at libusb:002:006
> This makes me think: Should there be a special device file for the
> scanner, like sane-find-scanner is looking for?

Maybe you contact Gernot privately. Gernot helped me a lot, but he is
very busy.


More information about the sane-devel mailing list