[sane-devel] xscanimage crashes with my Epson Stylus Office BX525WD

Torfinn Ingolfsen tingox at gmail.com
Sun Jul 3 18:52:15 UTC 2011

Hello again,

On Sat, Jul 2, 2011 at 11:47 AM, Torfinn Ingolfsen <tingox at gmail.com> wrote:
> Hello,
> On Fri, Jul 1, 2011 at 1:42 AM, Olaf Meeuwissen
> <olaf.meeuwissen at avasys.jp> wrote:
>> For GIMP plugins
>> you may want to try xsane or iscan.  The former should be packaged for
>> Xubuntu, the latter is available via
> I just tested xsane as a GIMP plugin on Xubuntu, and it works nicely. Thank you.

But on FreeBSD, xsane doesn't find the scanner automatically.
If I try just 'xsane' it says "no devices available".
If I try 'xsane epson2:net:' it works.
This makes it hard to use as a GIMP plugin. I tried a few things:
tingo at kg-v2$ SANE_NET_HOSTS="" xsane
tingo at kg-v2$ SANE_NET_HOSTS="epson2:net:" xsane
tingo at kg-v2$ SANE_DEFAULT_DEVICE="epson2:net:" xsane
but none of them worked ("no devices available" again).

All this on:
tingo at kg-v2$ uname -a
FreeBSD kg-v2.kg4.no 8.1-STABLE FreeBSD 8.1-STABLE #3: Thu Sep 16
22:18:48 CEST 2010     root at kg-v2.kg4.no:/usr/obj/usr/src/sys/GENERIC

tingo at kg-v2$ xsane -v
xsane-0.998 (c) 1998-2010 Oliver Rauch
  E-mail: Oliver.Rauch at xsane.org
  package xsane-0.996
  compiled with GTK-2.22.1
  with color management function
  with GIMP support, compiled with GIMP-2.6.11
  XSane output formats: jpeg, pdf(compr.), png, pnm, ps(compr.), tiff, txt

How can I get xsane on FreeBSD to recognize my scanner automatically?
Torfinn Ingolfsen

More information about the sane-devel mailing list