[sane-devel] Plustec MobileOffice S400

Tobias tobias.tandetzki at t-online.de
Sun May 15 08:47:54 UTC 2011


unfortunately I bought a new scanner (plustec MobileOffice S400) that is
not supported with linux.
I was not successful to get a colored scan with the gt86xx backend. 

Referring to 
here are the results trying to get it work with sane.

This is the output of >sane-find-scanner -q
found USB scanner (vendor=0x07b3, product=0x0465 [600dpi USB Scanner],
chip=GT-6816) at libusb:005:003

The output of >sane-find-scanner -v -v 
<device descriptor of 0x07b3/0x0465 at 005:003 (600dpi USB Scanner)>
bLength               18
bDescriptorType       1
bcdUSB                1.10
bDeviceClass          0
bDeviceSubClass       0
bDeviceProtocol       0
bMaxPacketSize0       64
idVendor              0x07B3
idProduct             0x0465
bcdDevice             5.01
iManufacturer         0 ()
iProduct              1 (600dpi USB Scanner)
iSerialNumber         0 ()
bNumConfigurations    1
<configuration 0>
bLength              9
bDescriptorType      2
wTotalLength         32
bNumInterfaces       1
bConfigurationValue  1
iConfiguration       0 ()
bmAttributes         160 (Remote Wakeup)
MaxPower             500 mA
  <interface 0>
   <altsetting 0>
   bLength            9
   bDescriptorType    4
   bInterfaceNumber   0
   bAlternateSetting  0
   bNumEndpoints      2
   bInterfaceClass    255
   bInterfaceSubClass 255
   bInterfaceProtocol 255
   iInterface         0 ()
    <endpoint 0>
    bLength           7
    bDescriptorType   5
    bEndpointAddress  0x81 (in 0x01)
    bmAttributes      2 (bulk)
    wMaxPacketSize    64
    bInterval         0 ms
    bRefresh          0
    bSynchAddress     0
    <endpoint 1>
    bLength           7
    bDescriptorType   5
    bEndpointAddress  0x02 (out 0x02)
    bmAttributes      2 (bulk)
    wMaxPacketSize    64
    bInterval         0 ms
    bRefresh          0
    bSynchAddress     0

<trying to find out which USB chip is used>
    checking for GT-6801 ...
    this is not a GT-6801 (bDeviceClass = 0)
    checking for GT-6816 ...
<This USB chip looks like a GT-6816 (result from sane-backends

found USB scanner (vendor=0x07b3, product=0x0465 [600dpi USB Scanner],
chip=GT-6816) at libusb:005:003


In the windows driver CD I found this two firmware files:
-rwxr-x--- 1 root root 8192 2011-05-08 11:00 cism216.fw
-rwxr-x--- 1 root root 8192 2011-05-09 19:43 cism603.fw

I tried some override in gt68xx.conf and found a working one:
usb 0x07b3 0x0465
override "plustek-opticslim-m12"

This is the result of scanning a test image with the override:
scanimage -x 100 -y 55 > image.override.png

This is the same test image with the Plustek software with Windows XP

I managed to compile and install sane-backends-git20110315 and to
extended gt68xx_devices.c with an entry for

I have tried to modify parameters (e.g. GT68XX_FLAG_ALWAYS_LINEMODE,
GT68XX_FLAG_NO_LINEMODE), but without any success to get a colored scan.

Here an example: COLOR_ORDER_RGB instead of COLOR_ORDER_BGR:

The result is nearly the same as with the override.

Is there anything else I can do to improve the scan result?

Best regards,

More information about the sane-devel mailing list