[sane-devel] Strange conflict with Wireless 300N USB adapter and CanoScan 9000F

Al Bogner sane at ml1103.bogner.priv.at
Wed Oct 5 11:46:59 UTC 2011

Maybe this is offtopic here, but I think it is not a problem of Gernot
Hassenpflug's driver for the CanoScan 9000F.

The driver works fine for me since months and to be sure, that it is
not a solved problem in the meantime, I compiled the driver yesterday
again from git.

If there is _no_ Digitus Wireless 300N USB adapter DN-7053-2
I get:

found USB scanner (vendor=0x04a9 [Canon], product=0x1908 [CanoScan]) at

/usr/local/bin/scanimage -L
device `pixma:04A91908' is a CANON Canoscan 9000F multi-function

So everything seems to be fine and I can scan with a frontend, like
xsane or gscan2pdf.

uname -r

cat /etc/issue
Ubuntu 11.04 \n \l

Now I attach the Digitus Wireless 300N USB adapter DN-7053-2 and look
what dmesg says at the end:

[   65.738706] hda-intel: IRQ timing workaround is activated for card
#2. Suggest a bigger bdl_pos_adj.

[   74.650040] usb 2-1: new high speed USB device using ehci_hcd and
address 2

[  786.454490] usb 2-1: USB disconnect, address 2

[ 3272.780049] usb 2-1: new high speed USB device using ehci_hcd and
address 3

[ 3512.861183] exe (12491): /proc/12491/oom_adj is deprecated, please
use /proc/12491/oom_score_adj instead.

[ 4280.150062] usb 2-6: new high speed USB device using ehci_hcd and
address 4

[ 4280.320704] r8712u: module is from the staging directory, the
quality is unknown, you have been warned.

[ 4280.328019] r8712u: DriverVersion: v7_0.20100831

[ 4280.328043] r8712u: register rtl8712_netdev_ops to netdev_ops

[ 4280.328046] r8712u: USB_SPEED_HIGH with 4 endpoints

[ 4280.329336] r8712u: Boot from EFUSE: Autoload OK

[ 4280.992489] r8712u: CustomerID = 0x0000

[ 4280.992493] r8712u: MAC Address from efuse = ...

[ 4280.994312] usbcore: registered new interface driver r8712u

[ 4281.770501] r8712u: 1 RCR=0x153f00e

[ 4281.771238] r8712u: 2 RCR=0x553f00e

[ 4281.881812] ADDRCONF(NETDEV_UP): wlan0: link is not ready

sane-find-scanner and scanimage still find the scanner, but when I use
eg gscan2pdf I get "Unbekannte Nachricht: scanimage: sane_read: Error
during device I/O" and "Unbekannte Nachricht: Scanned page 1. (scanner
status = 9)"

sane-find-scanner doesn't find the scanner after I opened a frontend
and tried to scan.

/usr/local/bin/scanimage -L
No scanners were identified.

I remove the Digitus Wireless 300N USB adapter DN-7053-2 and see with

[ 4575.934610] ehci_hcd 0000:00:13.2: force halt; handshake
ffffc90000624424 00004000 00000000 -> -110

[ 4575.934621] ehci_hcd 0000:00:13.2: HC died; cleaning up

[ 4575.934644] usb 2-1: usbfs: usb_submit_urb returned -110

[ 4575.934670] usb 2-1: USB disconnect, address 3

[ 4575.935143] usb 2-6: USB disconnect, address 4

I try again sane-find-scanner and scanimage and the scanner is not
found. After a reboot the scanner works fine again.


BCC to Gernot. Gernot please note my email-address has changed!

More information about the sane-devel mailing list