[sane-devel] Help with a genesys scanner

stef stef.dev at free.fr
Sun Sep 4 06:19:00 UTC 2011

Le samedi 3 septembre 2011 23:22:55 araneae, vous avez écrit :
> Hi, I recently purchased a Canon LiDE 1100 scanner. According to
> http://www.sane-project.org/lists/sane-mfgs-cvs.html#Z-CANON the
> status for this scanner is "Complete" and uses the genesys backend
> http://www.meier-geinitz.de/sane/genesys-backend/
> I compiled sane-backends-1.0.22 followed by sane-frontends-1.0.14 from
> source successfully. When I run sane-find-scanner I get this message:
> found USB scanner (vendor=0x04a9 [Canon], product=0x1909 [CanoScan],
> chip=GL124) at libusb:002:003
>   # Your USB scanner was (probably) detected. It may or may not be
> supported by # SANE. Try scanimage -L and read the backend's manpage.
> However, when I try scanimage, xscanimage, xcam, scanadf, none of
> these front ends detect the scanner, even when I run them as root.
> I'm running 2.6.31-17-generic #54-Ubuntu SMP x86_64 GNU/Linux
> Does anyone have any ideas to get this scanner to work?


	I suppose you mean LiDE 110, which is effectively supported. I think you 
should check your 'system' (ie in /etc/sane.d/) genesys.conf to see if is has 
been updated. By default the installation procedure (make install) doesn't 
overwrite existing configuration files, so it may just be a matter of copying 
the genesys.conf file from the compiled sources to its final place. 
	If it isn't enough, you might check the configuration option given to 
configure to see if they match the one from the previous installation.


More information about the sane-devel mailing list