[sane-devel] Canon LiDe 210 Genesys backend gone wrong

Jay Christnach jay.christnach at gmx.net
Wed Jun 27 14:27:51 UTC 2012

Hi, Thanks for not giving up on it.

1) system with working scanner:
Laptop HP625
Kernel 2.6.38-15-generic-pae #61-Ubuntu 32 bit
libusb-0.1-4 version 2:0.1.12-17
libusb-1.0-0 version 2:1.0.8-2

2) system where light doesn't turn on:
Abit Mainboard with AMD64X2 5600+
Kernel 3.2.0-25-generic #40-Ubuntu 32 bit
libusb-0.1-4 version 2:0.1.12-20
libusb-1.0-0 version 2:1.0.9-rc3-2ubuntu1

The problem occured also when both machines where running Ubuntu 11.04 
with the same kernel version except the one on the desktop was 64 bit.

Another hint: On the desktop running the scanner inside VirtualBox with 
Windows XP and the linux kernel 1)  above as the host OS it doesn't work 
for now. Although I recall that it worked once. The kernel versions are 
changing rather often nowadays along with the updates.

I found nothing relevant to USB in the BIOS, so I haven't tried anything 
in this direction.

There is no message being logged when the light doesn't turn on.

In the past I compiled some kernels from source, maybe I should try to 
revert to an older kernel for testing. I'm not sure if I'm able to get 
it to work though. Grub has got so complicated and I'm not sure if I run 
into problems with the versions of libc and so on.

Best greetings from Luxembourg

On 06/22/2012 06:36 AM, stef wrote:
> Hello,
>     I cannot reproduce this problem on my available hardware. For the 
> working and non working case,
> it would be interesting to know:
>     - the linux distribution
>     - the linux kernel version
>     - if the system is 32 or 64 bits
>     - the libusb version used
>     When the LED doesn't switch on, does 'dmesg' show any usb related 
> kernel message ?
> Regards,
>     Stef

More information about the sane-devel mailing list