[sane-devel] Canon LiDe 210 Genesys backend gone wrong

Jay Christnach jay.christnach at gmx.net
Sat Jun 30 16:02:32 UTC 2012

On 06/28/2012 09:25 PM, stef wrote:
> Le 28/06/2012 13:59, Jay Christnach a écrit :
>>> Hello,
>>>     thanks for all these data. I have uploaded at 
>>> http://dl.free.fr/gEzUYJkHX a small 'gl124' unit test program. It 
>>> does an uncorrected color scan at 150 dpi. It is a fully static 32 
>>> binary using libusb-1.0.9 . Put it in a directory, copy your 
>>> genesys.conf file in the same directory then run it. You should see 
>>> the lamp switch on. I'm curious to know how it behaves in the 
>>> "buggy" hardware combination.
>>> Regards,
>>>      Stef
>     OK,
>     now here's the same test program compiled against legacy libusb 
> 0.1 (and not through the compat libusb-1.0). If it still doesn't light 
> on the lamp, I think we can rule out a libusb problem:
> http://dl.free.fr/rm.pl?h=reyVJTLYp&i=48660014&s=XdEvMMX5NTGQlxGZp3zmhq6vZSkoY4FE 
> Regards,
>     Stef
Hello again,

I have some news:

The problem is intermittent! Sometimes after rebooting it works again, 
but then eventually fails again.

(These days I'm refoaming loudspeakers in my lab and I use a big power 
amp to test with a 2 Hz signal if the cone is centered. The amp 
sometimes triggers the circuit breaker while switching on, so that power 
is lost and I have to restart my computer. Usually I let it run all the 

By chance I tested your statically linked test program again and found 
it worked this time! I already suspected that the problem would be 
intermittent, but I was not sure when and how.

So be assured now, that there is no software problem. It is linked to 
the fact that I use some usb port to connect my smartphone. I did some 
testing when nothing but the scanner was connected and it didn't work. 
For the moment it works and I tried connecting the phone while scanning. 
The LEDs immediately went dark when I connected the plug. Unlugging it, 
it worked again.

I now also observed a few scans where the light went dark in the middle 
of the scan without the phone being connected.

I will try with different ports for my devices or maybe a powered hub 
and the problem should be solved. So Armin Stebich was right in that 
matter that it is a power over USB problem.

So sorry for bothering you and many thanks for your help. I'm pretty 
convinced that this issue is now solved.

Best greetings

More information about the sane-devel mailing list