[sane-devel] HP N6350

Random Quip Generator pseubodot at hotmail.com
Mon Apr 15 22:28:46 UTC 2013

Hi Gerard,

On 13-04-13 06:34 AM, Gerard Klaver wrote:
> For the HP N8460,
> Did you check for the sane-avision backend, IIRC some scanners with an
> avision C7 chipset are supported with this backend.

Thanks for the pointer.

'sane-find-scanner' didn't find the scanner when I ran it as root. I
subsequently added the USB string to the avision.conf file in /etc/sane.d.

After that, when I ran sane-find-scanner, I saw:

found USB scanner (vendor=0x03f0, product=0x3b05) at libusb:002:023

I then ran xscanimage as root, and was able to get a colour preview scan
of an image in the 'Preview Window' using 'Normal' as Scan source (using
the flatbed and not the sheet feeder). When I then clicked on the 'Scan'
button, an error box came up with: 'Hand-Scanner mode not supported'.

The scanner display window (small LED on the front of the scanner) reads
'DMA TimeOut' and required a power cycle to remove.

One power cycle later, I have no problem getting the 'Acquire Preview'
to scan an colour image several times. If I change 'Scan mode' from
Color to Gray, I can continue to get Preview images without issue. If I
choose 'Scan' from the main xscanimage window, however, I get the same
'Hand-Scanner model not supported' message on screen.


If I try to get a preview scan again, I get another error message dialog
box with 'Failed to start scanner: Error during device I/O.'

The display on the scanner itself gives the same 'DMA TimeOut' message.

So, 'preview scans' seem to work just fine, but finer scans so far do
not. I need to figure out how to grab debug info (I've read the avision
backend manpage and just need to figure out how to grab the volumes of
text that pass by).

Any other suggestions welcomed, I'll follow up with debug info as I get it.

Thanks and best, -- p

More information about the sane-devel mailing list