[sane-devel] Sane problem with Brother MFC J6710DW scanner.

upscope upscope at nwi.net
Tue Dec 10 15:59:37 UTC 2013

Since updating to KDE 4.11.4 my above scanner function has quite working 
with Sane backend applications. (xsane and aquireInages on openSUSE 12.3 
and 13.1. Also a Brothers Brscan-Skey does not work. These all worked on 
KDE 4.11.3 and earlier.

The actually failure is an Error message saying "invalid Argument"

Scamimage -L see the scanner:

rpl7:~> scanimage -L
device `brother4:bus3;dev6' is a Brother MFC-J6710DW USB scanner

linux-rpl7:~> lsusb
Bus 003 Device 006: ID 04f9:0263 Brother Industries, Ltd

rpl7:~> scanimage -T
scanimage: rounded value of br-x from 297 to 296.973
scanimage: rounded value of br-y from 420 to 419.962
scanimage: sane_start: Invalid argument

Originally I thought it was a failure in my MFC. But the application
Skanlite works fine. Apparently the bad argument is the start command.

When I use brscan-skey (scantofile) it is supposed to connect to the 
computer (USB connection, create a folder and then scan in the document.

It does connect to the computer, and create the folder but it never 
starts the scanner.

Starting xsane from the command. It starts, the GUI, header says:
"xsane 0.998 MFC-J6710DW scanner"

The error pops up: "Failed to start scanner: Invalid argument"

This is what always worked before KDE latest update.
There was an update to: libksane0-4.11.4-1.1.x86_64 as part of the kde 

# Brother MFC-J6710DW
ATTR{idVendor}=="04f9", ATTR{idProduct}=="0263",  MODE="0664", 
GROUP="lp", ENV{libsane_matched}="yes"

If you need any other info or tests, let me know. Meanwhile I keep looking.

Ant ideas would be greatly appriciated.

openSUSE 12.3(Linux 3.11.1-3.gfeffbf9-desktopp x86_64|
Intel(R) Quad Core(TM) i5-4440 CPU @ 3.10GHz|8GB DDR3|
GeForce 8400GS (NVIDIA-Linux-x86_64-331.20)|KDE 4.11.4

More information about the sane-devel mailing list