[sane-devel] Problem installing Canon MP270 scanner on debian wheezy

Rob Hill robhill at es.co.nz
Sun Jan 20 08:38:24 UTC 2013

-- Hello list, 

I am unable to install the scanner on a Canon MP270 printer/scanner on
a Debian Wheezy 32-bit stystem.  

Scanimage -V gives:  

scanimage (sane-backends) 1.0.22; backend version 1.0.22

The scanner is detected.  Scanimage -L gives: 

device `v4l:/dev/video0' is a Noname Integrated Camera virtual device
device `pixma:04A9173B_829B41' is a CANON Canon PIXMA MP270
multi-function peripheral

sane-find-scanner gives: 

found USB scanner (vendor=0x04a9 [Canon], product=0x173b [MP270
series]) at libusb:003:002

The directory /dev/usb/ contains lp0 (from the printer part of the
mp270) but no scanner device.  

If I try 

$ scanimage >file.pnm

I get:

scanimage: sane_start: Invalid argument

I've looked at the sane installation howto, and tried to create a
device manually, but with the same result.  

Any help will be appreciated. 


More information about the sane-devel mailing list