[sane-devel] Pls help SANE avision backend / Mac / HP

Brian services at increa.com
Sun Jan 20 07:05:31 UTC 2013

Dear SANE developers,
cc: Mike avision.conf maintainer,

On my laptop, sane-find-scanner finds the scanner, but scanimage -L will not

Running SANE on Mac OS 10.6.  
read the old message archives at http://www3.sane-project.org/old-archive/2001-07/0225.html
read the old message archives at https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/270185

Proper files are found, no error messages.
I ran as root, so permissions are not the issue.
I have all backends disabled except the one that advertises to work for my HP ScanJet 5300C
Tried running with stock avision.conf
Also tried uncommenting the USB vendor code line in avision.conf because the vendor and product codes match mine.

It just hangs.
After about 4 hours of debugging, I'm stuck.
Please help!

Here is a terminal dump:

bmmbp:~ brian$ su root
sh-3.2# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett Packard], product=0x0701 [Hewlett Packard ScanJet 5300C/5370C ]) at libusb:003:003-03f0-0701-00-00
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
sh-3.2# SANE_DEBUG_DLL=128 scanimage -L
[sanei_debug] Setting debug level of dll to 128.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.23git
[dll] sane_init/read_dlld: attempting to open directory `./dll.d'
[dll] sane_init/read_dlld: attempting to open directory `/usr/local/etc/sane.d/dll.d'
[dll] sane_init/read_dlld: using config directory `/usr/local/etc/sane.d/dll.d'
[dll] sane_init/read_dlld: done.
[dll] sane_init/read_config: reading dll.conf
[dll] add_backend: adding backend `avision'
[dll] sane_get_devices
[dll] load: searching backend `avision' in `/usr/local/lib/sane'
[dll] load: trying to load `/usr/local/lib/sane/libsane-avision.1.so'
[dll] load: dlopen()ing `/usr/local/lib/sane/libsane-avision.1.so'
[dll] init: initializing backend `avision'
[dll] init: backend `avision' is version 1.0.294

{everything hangs at this point, and I have to Cntrl-C out of it}


More information about the sane-devel mailing list