[sane-devel] Fujitsu ScanSnap S1300i

Peter D'Hoye peter.dhoye at gmail.com
Fri Mar 15 23:27:19 UTC 2013

Hi all,

I'm quite new to sane dev but kinda forced to it thanks to this
paperweight I want to convert into a scanner ;)

I got this fujitsu scansnap s1300i while looking for a portable duplex
scanner, and took the risk it would work with sane based on a post
somewhere [1]. Still in contact with that user to see if I can
duplicate his success, but that's a parallel plan.

I have the epjitsu configured correctly, including the required
firmwarefile for this scanner (log says it is loaded fine). Right now
sane complains about I/O error, I tried with several released
versions, current git and epjitsu patch 21 applied [2]. With that
patch I tried making it be detected as s300/1300 or s1100.

I have detailed logs of both attempts:

- when using model s300/1300, the backend errors with coarsecal2:
[epjitsu] coarsecal: c6 payload bad status?
[epjitsu] sane_start: ERROR: failed to coarsecal2

- when using model s1100, the backend fails with finecal:
[epjitsu] read_from_scanner: got GOOD/EOF (65536)
[epjitsu] read_from_scanner: finish rB:11520 len:65536
[epjitsu] read_from_scanner: start rB:11528 len:11528
[epjitsu] do_cmd: start
[sanei_usb] sanei_usb_read_bulk: trying to read 11528 bytes
[sanei_usb] sanei_usb_read_bulk: read failed: No such device
USB error: could not clear/halt ep 129: No such device

I also have wireshark USB captures of startup and doing a scan in a
Windows VM [3].

Is there anybody (Allan?) willing to assist in adding this hardware to
the supported list?


[1] http://askubuntu.com/questions/178833/scanner-detected-with-sane-find-scanner-but-not-with-scanimage-l-or-sudo-scani
[2] http://old.nabble.com/attachment/33334187/0/epjitsu-21.diff.zip
[3] https://dl.dropbox.com/u/32135165/s1300i_capture.zip

More information about the sane-devel mailing list