[sane-devel] Help needed diagnosing strange failure to scan with Samsung SCX-4500W

Mike Cloaked mike.cloaked at gmail.com
Thu May 9 15:50:39 UTC 2013

On Mon, May 6, 2013 at 9:12 PM, Mike Cloaked <mike.cloaked at gmail.com> wrote:

> I have a strange scanner failure to try to resolve, and I am hoping that
> an expert on this list may be able to help me fix the problem.
> I have a Samsung SCX-4500W multifunction printer that is plugged in to the
> usb port of my main machine running arch linux x86_64.  The printer part
> works fine with the Splix driver, but the scanner fails to work.
> When I unplug the device and plug it into a laptop running arch linux, it
> works fine. On a second laptop also running arch linux the scanner
> functions also work fine (xsane). However plugging the same device back in
> to my main desktop the scanner fails to work.
> Some information is as follows:
> sane-find-scanner works as either root or user and yields lines including:
> found USB scanner (vendor=0x04e8 [Samsung Electronics Co., Ltd.],
> product=0x342b [SCX-4500W Series]) at libusb:001:007
>   # Your USB scanner was (probably) detected. It may or may not be
> supported by
>   # SANE. Try scanimage -L and read the backend's manpage.
> scanimage -L works the first time I issue the command but then
> subsequently fails:
> scanimage -L
> device `xerox_mfp:libusb:001:006' is a Samsung Samsung SCX-4500W Series
> multi-function peripheral
> scanimage -L
> No scanners were identified. If you were expecting something different,
> check that the scanner is plugged in, turned on and detected by the
> sane-find-scanner tool (if appropriate). Please read the documentation
> which came with this software (README, FAQ, manpages).
> The device is listed correctly with the lsusb command:
> Bus 001 Device 007: ID 04e8:342b Samsung Electronics Co., Ltd
> The file /etc/sane.d/xerox_mfp.conf does have the correct line for the
> device:
> # Samsung SCX-4500W
> usb 0x04e8 0x342b
> The system log files contain lines like:
> May  6 16:43:27 localhost kernel: [ 8041.053060] usb 1-4: usbfs: interface
> 1 claimed by usblp while 'xsane' sets config #1
> I have tried unplugging the device and replugging it but nothing I do ever
> seems to make any difference.  I also removed the .sane directory from the
> user and started from new and nothing changed.
> The udev rules file seems fine and in less
> /lib64/udev/rules.d/53-sane.rules the lines relevant to the device are:
> # Samsung SCX-4500W
> ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="342b", MODE="0664",
> GROUP="scanner", ENV{libsane_matched}="yes"
> The system is fully up to date, and runs with systemd. The two laptops one
> of which is x86_64 and the other i386 are both the same arch setup, and
> both up to date. They work but the main machine does not.
> Can anyone suggest how I might be able to narrow down where the problem
> may lie?
> Many thanks for any help.
> Having tried to follow up on the post I saw about the Pulstek OpticBook
3800, I tried to do something analogous but it did not seem to work so I
probably did not have the correct syntax.

However I tried (in arch linux):

sudo sane-find-scanner

which gave the device as:
found USB scanner (vendor=0x04e8 [Samsung Electronics Co., Ltd.],
product=0x342b [SCX-4500W Series]) at libusb:001:009

Then I tried the command:
sudo SANE_DEBUG_XEROX_MFP=256  scanimage -d xerox_mfp:libusb:001:009 -v -v
-v -v -v 2> scan-debug-1.txt

and the file contains:

[sanei_debug] Setting debug level of xerox_mfp to 256.
[xerox_mfp] sane_init: Xerox backend (build 13), version != null, authorize
!= null
[xerox_mfp] sane_xerox_mfp_open: 'libusb:001:009'
[xerox_mfp] sane_xerox_mfp_get_devices: (nil), 1
[xerox_mfp] list_one_device: libusb:001:009
[xerox_mfp] usb_dev_open: open 0x21e93c0
[xerox_mfp] :: dev_command(INQUIRY[0x12], 70)
[xerox_mfp] usb_dev_request: sanei_usb_read_bulk: Error during device I/O
[xerox_mfp] dev_command: dev_request: Error during device I/O
[xerox_mfp] usb_dev_close: closing dev 0x21e93c0
[xerox_mfp] list_one_device: dev_inquiry(libusb:001:009): Error during
device I/O
scanimage: open of device xerox_mfp:libusb:001:009 failed: Invalid argument
Calling sane_exit
scanimage: finished

Did I get the command syntax incorrect?  I would appreciate any help with
this - but this seems to be unable to open the device so I don't know how
to proceed to get some definitive information about that is going wrong.

Thanks for any help.

mike c
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20130509/2fc96ddc/attachment.html>

More information about the sane-devel mailing list