[sane-devel] Pulstek OpticBook 3800 - problems with openning device on 1.0.23+

Nikolay Shaplov dhyan at nataraj.su
Sun May 12 08:54:21 UTC 2013

>      since the ASIC used is a GL845, you should not try forcing it to
> GL847. They are really different, and nothing will ever work. If you
> look at the GL845 datasheet, you'll see it is really close to the GL846.
> So close in fact that the same code should be able to run both.

1. I've build git version with setting GL846 chipset to 3600 clone in the 
model description. It gives the same result as I wrote before

2. In 1.0.22 GL847 worked for me well. It stopped working in 1.0.23. So I 
think this is not an chipset issue. (if at least there were no great changes 
in genesys_gl847.c)

>      Since I added preliminary support for GL846 a couple of months ago,
> you'd rather declare your scanner as a GL846 one like the
> canon_formula101_model.
I've tried... scanimage -L does not list scanner at all in this case O_o

Very strange for me... :-(((

>      Since having the ASIC datasheet isn't enough( GPIO, fontend, motors
> change from one model to another and are not coverd by this
> documentation), the process to reach full support is to run the
> experimental backend and compare debugging output with USB logs recorder
> under windows, and tweak the code until it works.

More information about the sane-devel mailing list