[sane-devel] Canon Pixma MG7550

Ueli u.buechler at intergga.ch
Sun Nov 16 22:48:44 UTC 2014


For my new Canon Pixma MG7550 I built and installed Sane 1.0.25 as described.

The scanner is connected with USB.

Here my findings:

'scanimage -L' finds the scanner
'scanimage -T' passed all tests

XSane started and one “aquire preview” in color-mode seemed to work. After 
switching to grayscale a preview hung and XSane had to be killed.

"scanimage -T" output:
	scanimage: scanning image of size 638x877 pixels at 24 bits/pixel
	scanimage: acquiring RGB frame, 8 bits/sample
	scanimage: reading one scanline, 1914 bytes...

scanimage was waiting indefinitely. 
When I switched off the scanner scanimage correctly reported an "error during 
device I/O".
After turning on the scanner again scanimage still hung.

Then I turned the scanner again off and on and started scans with scanimage 
with the following command:
scanimage --format tiff --resolution $res --mode $mode --verbose -x 10 -y 10 > 

This worked as expected for all supported resolutions and modes.

After that success I tried xsane again, and it worked(?).
Could it be that scanimage initializes the scanner correctly whereas xsane 
(and Gimp) don't do it?

Let me add one minor point to the build-process:
"make configure" warned me that usb-support is not included and that probably 
the usb-header file is missing. But it did not tell me to add the option 
--enable-libusb_1_0. That hint would have saved me some time looking at the 

Please tell me if I can be of any help testing an improved version of the 


More information about the sane-devel mailing list