[sane-devel] Problems scanning with front-ends on Canon CanoScan LiDe 25

"Cedric Bhihe (毕生泰)" cedric.bhihe at gmail.com
Wed Apr 29 10:35:58 UTC 2015

Greetings !
Before about 2 months ago, my Canon LiDE25 worked perfectly well in my 
Ubuntu Desktop 14.04.x environment . It had done so
Then all at once I found myself battling with a scan malfunction.
I tried using "Xsane Image scanning program", then "Simple Scan" then 
"gscan2pdf" on an up-to-date installation of Desktop Ubuntu 14.04.x. HW 
is an old HP Intel 8510w with 3 USB ports. All ports were tested, 
function well and behave the same.


1 - plug the flatbed scanner in any USB port
-- nothing happens (no noise, no movement).

2 - from terminal:
 >  scanimage -L
device `plustek:libusb:005:004' is a Canon CanoScan LiDE25 flatbed scanner
-- correct detection

3 - in the Plustek-SANE back-end configuration file, 
/etc/sane.d/plustek.conf, I inserted:
    # for Canon CanoScan LiDE 25
    [usb] 0x04A9 0x2220
    device /dev/usbscanner
although later positionned in the same file, and in the same [usb] 
section, I discovered
    device auto

4 - from terminal:
 > scanimage -x 100 -y 200 >output-trial.tiff
or simply
 > scanimage >output.tiff
-- both produce a correct although low res color image _every_ single time.

5 - when using either "Xsane Image scanning", "Simple Scan" or 
"gscan2pdf",  the response ot Canon LiDE 25 becomes comletely erratic.
Either it does not respond at all or responds once every 20 trials with 
a correct scan and then not at all.  Almost a complete no go ! Very 
surprising given that up until about two months ago, everything worked 
When clicking repeatedly on the scan button of any of the above 
mentionned Sane grafical front-ends, a message can appear saying that no 
scanner is detected. It does not always appear. More often there is 
simply either no response or null data acquisition without an actual 
physical scan, i.e. the raster-arm does not move.  Null-data 
acquisitiopn translates as a uniform black or grey or white preview 
(when preview is available).
Sometimes after the only possible first scan , the scanning raster-arm 
does not come back to its home position. The scanner is therefore not 
available anymore. Making it come back, involves quitting the frontend, 
unplugging the scanner, plugging it in again. and relaunching. This 
never happens from terminal.

I have read past posts posted on the subject during the past 10 weeks, 
in particular those of lszkclek at yahoo.com 
/and that jsmeix at suse.de 
but somehow I doubt that this is a USB port problem as everything works 
well from terminal , plus I don't deal with a Suse type distro. Ubuntu 
relies on "deb" packages not "rpm".

I am stumped.
Is this rather a front-end problem ? It sure looks like it.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20150429/04a10440/attachment.html>

More information about the sane-devel mailing list