[sane-devel] Canon MF212w Scanner and SANE

Scott monkity at gmail.com
Fri Dec 4 01:05:57 UTC 2015

Olaf, thank you for your continued help.  Yes, I am a newbie to this 
driver business among many things.

On 12/03/2015 04:52 AM, Olaf Meeuwissen wrote:
> Hi Scott,
> monkity writes:
>> Hi Olaf,
>> Olaf writes:
>>> [...]
>>> Have you tried sane-backends-1.0.25.  That versions claims that support
>>> for the MF210 Series was added to the pixma backend.
>>> Seeing that you are using Linux Mint, I *guess* that you get your SANE
>>> backends via the Ubuntu package archives.  The version in Ubuntu's wily
>>> (1.0.25+git20150528) appears to be new enough.
>>> # The Changelog mention the addition on 2015-04-03.
>> Unfortunately nothing is that easy.  Mint doesn't download the 1.0.25
>> backend with SANE; in fact it doesn't seem to do anything with respect
>> to backends.  I'm afraid I'm going to have to build the backend from
>> scratch, and I have no experience with this.
>> I did find a copy of 1.0.25 on
>> http://www.linuxfromscratch.org/blfs/view/svn/pst/sane.html.
>> That page, https://help.ubuntu.com/community/sane, and others aren't
>> really designed for Mint and newbies though.  Where should I start?
> Uh-oh, newbie alert ;-)
> First, check that you have the libsane package installed.  From a
> terminal, run
>    $ dpkg-query -W libsane
> If that produces something like
>    libsane:amd64    1.0.25-2
> things look good.  If, instead you get something like
>    dpkg-query: no packages found matching libsane
> there is more work to do but I assume for now that libsane is found.
> # If not, stop here and get back to me via the mailing list.
> In that case, you can probably get away with downloading the Ubuntu
> libsane package from
>    http://packages.ubuntu.com/wily/libsane
> Just make sure to pick the correct architecture.
> Once downloaded, run
>    $ sudo dpkg -i libsane-1.0.25+git20150528-1ubuntu2_amd64.deb
> and you should be good to go.
> Hope this helps,

So I ended up trying to install both i386 and amd64 versions. When I 
updated these, I got errors, and had to fix broken packages. After I did 
that, my SANE installation didn't work and the query you gave me gave 
the following result, even after removing SANE and reinstalling it.

$ dpkg-query -W libsane
libsane:amd64 1.0.23-3ubuntu3.1
libsane:i386 1.0.25+git20150528-1ubuntu2

So I then redid the command on the amd64 deb:

$ sudo dpkg -i libsane_1.0.25+git20150528-1ubuntu2_amd64.deb
[sudo] password for flibberty:
(Reading database ... 194182 files and directories currently installed.)
Preparing to unpack libsane_1.0.25+git20150528-1ubuntu2_amd64.deb ...
Unpacking libsane:amd64 (1.0.25+git20150528-1ubuntu2) over 
(1.0.23-3ubuntu3.1) ...
dpkg: dependency problems prevent configuration of libsane:amd64:
libsane:amd64 depends on libsane-common (= 1.0.25+git20150528-1ubuntu2); 
Version of libsane-common on system is 1.0.23-3ubuntu3.1.
libsane:amd64 depends on libgphoto2-port12 (>= 2.5.6); however:
Package libgphoto2-port12 is not installed.

dpkg: error processing package libsane:amd64 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Now my query came out as follows:
$ dpkg-query -W libsane
libsane:amd64 1.0.25+git20150528-1ubuntu2
libsane:i386 1.0.25+git20150528-1ubuntu2

SANE is still not recognizing my Canon.  Do the errors above give you 
any new ideas for me to try?

Thanks again,

More information about the sane-devel mailing list