[sane-devel] Canon MF212w Scanner and SANE

Olaf Meeuwissen paddy-hack at member.fsf.org
Fri Dec 4 13:22:39 UTC 2015

Scott writes:

> Olaf, thank you for your continued help.  Yes, I am a newbie to this 
> driver business among many things.
> On 12/03/2015 04:52 AM, Olaf Meeuwissen wrote:
>> Hi Scott,
>> monkity writes:
>>> Hi Olaf,
>>> Olaf writes:
>>>> [...]
>>>> Have you tried sane-backends-1.0.25.  That versions claims that support
>>>> for the MF210 Series was added to the pixma backend.
> [...]
>> Once downloaded, run
>>    $ sudo dpkg -i libsane-1.0.25+git20150528-1ubuntu2_amd64.deb
>> and you should be good to go.
> So I ended up trying to install both i386 and amd64 versions. When I 
> updated these, I got errors, and had to fix broken packages. After I did 
> that, my SANE installation didn't work and the query you gave me gave 
> the following result, even after removing SANE and reinstalling it.

Sorry.  I tried to take a shortcut and you ended up with a "mess".
Let's see if we can clean that up.

Please read this mail to the end before you start doing stuff.

> $ dpkg-query -W libsane
> libsane:amd64 1.0.23-3ubuntu3.1
> libsane:i386 1.0.25+git20150528-1ubuntu2

That surprised me a bit so I pulled down the Linux Mint 17.2 64bit image
and fired up a virtual machine to make sure that I knew what is going
on.  Looks like Linux Mint installs a number of packages for both 32 and
64 bit architectures and libsane is one of them.

> So I then redid the command on the amd64 deb:
> $ sudo dpkg -i libsane_1.0.25+git20150528-1ubuntu2_amd64.deb
> [...]
> libsane:amd64 depends on libsane-common (= 1.0.25+git20150528-1ubuntu2); however:
> Version of libsane-common on system is 1.0.23-3ubuntu3.1.
> libsane:amd64 depends on libgphoto2-port12 (>= 2.5.6); however:
> Package libgphoto2-port12 is not installed.
> dpkg: error processing package libsane:amd64 (--install):
> dependency problems - leaving unconfigured
> Errors were encountered while processing:
> libsane:amd64

I obviously forgot about the libsane dependencies.  My bad.
I have reproduced your situation in that virtual machine of mine.

> Now my query came out as follows:
> $ dpkg-query -W libsane
> libsane:amd64 1.0.25+git20150528-1ubuntu2
> libsane:i386 1.0.25+git20150528-1ubuntu2

To back out of this, use:

  sudo apt-get install libsane=1.0.23-3ubuntu3.1 libsane:i386=1.0.23-3ubuntu3.1

This will downgrade the currently "installed" versions and get you back
to a clean slate.  You can check with:

  sudo dpkg --audit

Things are okay if that produces no output.

Now on to getting the libsane package from Ubuntu's wily installed.

> SANE is still not recognizing my Canon.  Do the errors above give you 
> any new ideas for me to try?

First let's add the Ubuntu repositories to your list of package archives
the way it's supposed to be done.  Copy the attached 00-ubuntu-wily.list
to /etc/apt/sources.list.d/ and update your available package
information, like so

  sudo cp 00-ubuntu-wily.list /etc/apt/sources.list.d
  sudo apt-get update

This should download a couple of files from archive.ubuntu.com.

Next, lest you end up turning your Linux Mint into Ubuntu's wily almost
completely ;-), copy the attached 00-ubuntu-wily.pref to

  sudo cp 00-ubuntu-wily.pref /etc/apt/preferences.d

Now we are ready to:

  sudo apt-get install -t wily libsane

I tried this on my virtual machine and all went well.  Hope it will for
you to.

In case you are curious about what's going on, have a look at the
following manual pages (using the man command):


Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
Support Free Software               Support the Free Software Foundation
https://my.fsf.org/donate                        https://my.fsf.org/join
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 00-ubuntu-wily.list
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20151204/25a93633/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 00-ubuntu-wily.pref
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20151204/25a93633/attachment-0001.ksh>

More information about the sane-devel mailing list