[sane-devel] Canon LiDE 210 and grinding noises

Michael raselmsh at hotmail.com
Fri Jul 10 09:56:03 UTC 2015

Michael writes:
> I was wondering if anyone can help me regarding problems using my scanner,
a CanonLiDE 210, on Ubuntu 14.10,
> libsane 1.0.24-1.1ubuntu1.  It worked previously with Ubuntu 14.04,
libsane 1.0.23.  Now when I try
> to scan (with xsane or simple-scan), it usually aborts with a grinding
noise and I have to disconnect the
> scanner.  It works with a different system running OS X.  On-line searches
suggest that this is a known
> class of problem.
> Downgrading to the Ubuntu 14.04 package helped last time I tried it,
though I seem to recall that the
> previous time it did not.  sane-backends from git did not, though I did
build it as an Ubuntu package,
> including Ubuntu patches (except the couple which would not apply).

Coming back to this over half a year later.  I found a number of reports
today regarding scanner problems with Sane and USB3, followed the
suggestions of disabling USB3 in my BIOS and lo and behold, I was
immediately able to scan two pages (not yet tried more) without any trouble.
 Running "scanimage --test" now also works.

$ apt-cache policy libsane
  Installed: 1.0.25-git20150121-utopic0

Ditto for sane-utils.  Anything I can do to help move this along?  I do have
some programming skills, including basic understanding of the USB protocol
and Linux's usb_device sub-system, though I am chronically short of time
(aren't we all?)

More information about the sane-devel mailing list