[sane-devel] Problem with pixma mx535 network scanner

Graham Perry grhm.perry+deb at gmail.com
Sat Jun 27 18:16:19 UTC 2015

That seems to have done the trick, thanks.


But just for completeness:

1. Yes, scanimage -L did find the scanner on the last git version, it only
failed when trying to connect. The only version it doesn't find it on is
the current stable (1.0.24).
2. My build environment is gcc-multilib 5.1.0-4, autoconf 2.69-2, automake
1.15-1, binutils 2.25-5, make 4.1-1 and the kernel is 4.0.6-1-ARCH.

Hope that helps. Thanks again.

On 27 June 2015 at 18:09, Louis Lagendijk <louis at fazant.net> wrote:

> On Sat, 2015-06-27 at 15:33 +0100, Graham Perry wrote:
> > Thanks, but I had already tried that. Tried again with the same
> > result. /usr/lib64/sane only contains .1.0.25 versions.
> >
> Please pull the latest version of the bjnp-code from git: I added some
> more debugging code and fixed a nasty missing return in the opening of
> the connection to the scanner: this could have caused your problems. It
> is strange however that we never encountered this before: what
> compiler/version are you using?
> And if it still does not work:
> What does a scanimage -L return? Does it list the scanner? I would
> assume it does, but I want to be sure.
> Kind regards, Louis
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20150627/19ff5011/attachment-0001.html>

More information about the sane-devel mailing list