[sane-devel] Epson Perfection V800 error

Ron Falkowski ronfalkowski92 at gmail.com
Tue May 19 22:44:57 UTC 2015

On Tue, May 12, 2015 at 7:23 PM, Olaf Meeuwissen <olaf.meeuwissen at avasys.jp>

> Ron Falkowski writes:
> > Thank you very much for the help. The V800 now works perfectly, at least
> as
> > root. "scanimage -L" still does not find the new scanner as a normal
> user.
> > Just changing the permissions with "chmod a+rw /proc/bus/usb/001/013" did
> > not seem to work. Going through the FAQ eventually led me to tools/udev.
> I
> > added the following lines to libsane.rules:
> >
> > ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="0151", MODE="0664",
> > GROUP="scanner", ENV{libsane_matched}="yes"
> > # EPSON GT-X980 | EPSON Perfection V800 Photo
> >
> > which is just the lines for the V700 with the product ID changed. However
> > I'm not sure what to do with this new file. Rebuilding after I changed
> this
> > file seemed to have no effect.
> That file needs to be installed in /etc/udev/rules.d/.  This is probably
> not done as part of the regular `make install` as it may not be needed
> for some setups.  You can copy it there with any name as long as it ends
> with a .rules suffix.  After the copy, run
>   sudo udevadm control --reload_rules
> to make sure that udev notices and reconnect the device.
> Hope this helps,
> --
> Olaf Meeuwissen, LPIC-2           FLOSS Engineer -- AVASYS CORPORATION
> FSF Associate Member #1962               Help support software freedom
>                  http://www.fsf.org/jf?referrer=1962

This worked. Thanks again.

In return I have another patch for you all. As it is, the V800s cannot scan
with the "TPU8x10" source setting. I eventually figured out that this is
because the other scanners that have this option are listed explicitly in
e2_discover_capabilities(). This needs to be changed to include the V800.

epson2-ops.c Line 718:
        if (e2_model(s, "GT-X800") || e2_model(s, "GT-X900")) {

change to:
        if (e2_model(s, "GT-X800") || e2_model(s, "GT-X900") || e2_model(s,
"GT-X980")) {

I'll leave writing the patch and committing it to those who know what
they're doing in case anything else needs to be changed too, but this
worked for me.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20150519/de9a35f7/attachment.html>

More information about the sane-devel mailing list