[sane-devel] Xsane can't find scanner - again, but this one is USB

MR ZenWiz mrzenwiz at gmail.com
Fri Oct 30 06:12:32 UTC 2015

Last time I had this problem, it was on my laptop at my friend's house
with a wireless HP Envy printer.  Eventually that worked when I added
the printer through CUPS.

At home, I run Xubuntu 14.04.3 with an HP 5740 all-in-one attached on
the USB (bus 3, device 14).

When I first installed this it was fine, everything worked.

Tonight I tried to scan a document, and xsane can't find the

I removed it with CUPS and reinstalled - no change.

I removed it and used the Xubuntu printer manager to install it, and
even printed a test page, and that works, and it now shows up in CUPS,
but xsane still can't find the scanner.

Why does xsane have so much trouble locating what's there and operational?

How does it manage to forget what used to be there (and still is)?

(For the record, hp-setup also can't seem to find the device, even
when I tell it the USB bus and device id.).

So what else do I need to do to get xsane to recognize this thing
again so I can use it?

At this point I have to go back to my Canon LiDE scanner, which I like
but it has no feeder.

This is most frustrating.  I hate to say it, but Windows never has
this problem, and I'm no fan of that PoS.


More information about the sane-devel mailing list