[sane-devel] Xsane can't find scanner - again, but this one is USB

MR ZenWiz mrzenwiz at gmail.com
Fri Oct 30 06:33:57 UTC 2015

I forgot to mention - I rebooted the machine and this still happens.

I realize that's the Windows solution, but I never saw any problems
like this when I was using Windows, and no, that's not an acceptable
solution either.

On Thu, Oct 29, 2015 at 11:32 PM, MR ZenWiz <mrzenwiz at gmail.com> wrote:
> It's worse.
> I plugged in my Canon LiDE scanner and it shows up on lsusb:
> mar at marbase:~ $ lsusb
> Bus 002 Device 002: ID 8087:8001 Intel Corp.
> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 001 Device 002: ID 8087:8009 Intel Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 003 Device 008: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30
> Bus 003 Device 002: ID 04f9:0040 Brother Industries, Ltd
> Bus 003 Device 005: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
> Bus 003 Device 006: ID 413c:2011 Dell Computer Corp. Multimedia Pro Keyboard
> Bus 003 Device 004: ID 413c:1005 Dell Computer Corp. Multimedia Pro Keyboard Hub
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> xsane hung after this.  I unplugged the scanner and plugged the HP
> back in, and the Canon showed up in xsane, but of course it didn't
> work.  I switched the cable back, and xsane hung again.  So I ran
> sane-find-scanner:
> mar at marbase:~ $ sudo sane-find-scanner
> [sudo] password for mar:
>   # sane-find-scanner will now attempt to detect your scanner. If the
>   # result is different from what you expected, first make sure your
>   # scanner is powered up and properly connected to your computer.
>   # No SCSI scanners found. If you expected something different, make sure that
>   # you have loaded a kernel SCSI driver for your SCSI adapter.
> found USB scanner (vendor=0x04a9 [Canon], product=0x220e [CanoScan])
> at libusb:003:008
>   # Your USB scanner was (probably) detected. It may or may not be supported by
>   # SANE. Try scanimage -L and read the backend's manpage.
>   # Not checking for parallel port scanners.
>   # Most Scanners connected to the parallel port or other proprietary ports
>   # can't be detected by this program.
> Now xsane can't find any scanner, so I can't scan anything.
> WTF?
> On Thu, Oct 29, 2015 at 11:12 PM, MR ZenWiz <mrzenwiz at gmail.com> wrote:
>> Last time I had this problem, it was on my laptop at my friend's house
>> with a wireless HP Envy printer.  Eventually that worked when I added
>> the printer through CUPS.
>> At home, I run Xubuntu 14.04.3 with an HP 5740 all-in-one attached on
>> the USB (bus 3, device 14).
>> When I first installed this it was fine, everything worked.
>> Tonight I tried to scan a document, and xsane can't find the
>> scanner/printer/etc.
>> I removed it with CUPS and reinstalled - no change.
>> I removed it and used the Xubuntu printer manager to install it, and
>> even printed a test page, and that works, and it now shows up in CUPS,
>> but xsane still can't find the scanner.
>> Why does xsane have so much trouble locating what's there and operational?
>> How does it manage to forget what used to be there (and still is)?
>> (For the record, hp-setup also can't seem to find the device, even
>> when I tell it the USB bus and device id.).
>> So what else do I need to do to get xsane to recognize this thing
>> again so I can use it?
>> At this point I have to go back to my Canon LiDE scanner, which I like
>> but it has no feeder.
>> This is most frustrating.  I hate to say it, but Windows never has
>> this problem, and I'm no fan of that PoS.
>> MR

More information about the sane-devel mailing list