[sane-devel] scanadf on HP 8250 for "ADF Duplex" causes segfault

James Klaas jklaas at appalachian.dyndns.org
Wed Jul 6 23:37:44 UTC 2016

I am running Debian 8 (Jessie) and when I attempt to use the Duplex on my
HP8250 I get a segmentation fault.

I was running sane-utils 1.0.24-8+deb8u1 and had read on the list of the
many improvements in 1.0.25, so I got the source package for Debian Stretch
which is 1.0.25-2 and built and installed the debs.

If I run 'scanadf --source="ADF Duplex"', the scanner pulls in the first
page, scans it the top, flips the page over, appears to scan it. then dies
with the message:

Scanned document image-0001
Segmentation fault (core dumped)

If I run scanadf on the machine the scanner is attached to, there's a dmesg:

[517673.237090] scanadf[26462]: segfault at 0 ip 00007f610e255480 sp
00007f610391ac10 error 4 in libc-2.19.so[7f610e1eb000+1a2000]

If I run scanadf remotely, I get the following in dmesg:

[518945.499997] saned[2623]: segfault at 0 ip 00007f937d6c8480 sp
00007f9376fe6bd0 error 4 in libc-2.19.so[7f937d65e000+1a2000]

I captured an strace of running scanadf if that will be of help.

Running the ADF for just one side (scanadf --source="ADF Front") seems to
work pretty flawlessly.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20160706/7775cb88/attachment.html>

More information about the sane-devel mailing list