[sane-devel] Canon Pixma MG5740 Multifunction Printer

Eric&Yvonne maws at cybersmart.co.za
Mon Jul 11 20:53:11 UTC 2016

This is my first post to Sane and I trust that I am sending it to the 
correct forum.

I have just purchased a Canon Pixma MG5740 and tried to interface it 
with my system comprising a Ubuntu 16.04 64bit operating system.
I first connect the device using a USB cable and was able to print but 
could not get the scanner to work. Running lsusb resulted in the 
following message

Bus 001 Device 005: ID 04a9:178e Canon, Inc.

I then tried setting up the device in wifi mode by adding mfnp 
:// to the pixma.conf file. Running scanimage -L produced 
this result

[bjnp] udp_command: ERROR - no data received
[bjnp] bjnp_init_device_structure: Cannot read mac address, skipping 
this scanner
[bjnp] udp_command: ERROR - no data received
[bjnp] add_scanner: ERROR - Cannot read scanner make & model: 
I confirmed that the address is correct for the MG5740

I can access the printer in both USB and WIFI mode.
Any advice on how I may resolve the scanner issue would be much appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20160711/bb2c2924/attachment.html>

More information about the sane-devel mailing list