[sane-devel] Peculiar behavior of Canon Scanner

Alan McConnell alan at his.com
Tue Jul 12 13:21:02 UTC 2016

Assembled Wisdom!

I am running Debian jessie, and I have a Canon MF4770n Three-in-One,
connected to my computer with a USB cable.

It worked great in wheezy, but now I'm having problems.  Re scanning:
I have used scanimage to scan a page to a file and the scan functions
flawlessly.  But then, when I try to scan a second page, there is an
unconscionably long wait, then  scanimage  exits with an error
message, leaving a stub of 35 bytes.  I turn the printer off, then
on again, and I can again scan but one page, getting the same error
a second time.

My questions: why is this occurring?  is it a fault of the MF4770n,
or a bug in   scanimage ?  Guesses and suggestions for further
tests are welcome!

I might add: I can't now print at all with this machine.  I've written
the cups E-list about this many times.  I am frustrated, because this
Canon worked well with wheezy.



Alan McConnell :  http://globaltap.com/~alan/
       They finally got King Midas, I hear.  Gild by association.
       What a giftless bastard! (Tchaikovsky, about Brahms)

More information about the sane-devel mailing list