[sane-devel] Need sane docs

m. allan noah kitno455 at gmail.com
Wed May 4 11:27:01 UTC 2016

Gene- if your scanner has ethernet connectivity, you don't need to use
the net backend or saned. Those are basically adapters that allow you
to convert a non-networked scanner into a networked one, by using a
saned server as an intermediary.

I think you need to see if the brother docs list any debugging options
for the brother4 backend. Without more debugging info from that
backend, you are stuck.


On Tue, May 3, 2016 at 11:58 PM, Gene Heskett <gheskett at shentel.net> wrote:
> On Tuesday 03 May 2016 20:52:35 m. allan noah wrote:
>> Well, that implies that we are handing control to the brother4
>> backend, but it is not finding any scanners. Perhaps try the same as
>> root?
>> allan
> That wasn't any help, but since the vendor/product was found when I
> plugged in a USB cable, running xsane then found it at the usb bus and
> address, and I ran a few scans.  Seems to work about as expected and I
> believe at a better color accuracy than the epson NX-515 scanner eve
> produced.  The gamma, brightness and contrast controls seemed to work
> backwards but they worked and I finally saved a profile of gamma=1.00,
> brightness and contrast at 0.00 so I'd have a default starting point.
> But this unit has its usb and ethernet connections on the top, with a
> molded plastic ditch for cable guidance that leads out the right rear of
> the top cover, using up 2 feet of cable while still inside the machine,
> so the 7 port hub its plugged into is now hanging about 18" up in the
> air with the other 5 cables hanging down from the other face.  hell of a
> way to run a train.  And the next usb extension cord I have is a 10
> meter.
> Because the usb hookup is such a kludge,  and I have no problem talking
> to it from a web browser, I would much rather use the ethernet
> connection cable that is driving the printer from cups.
> So I am thinking I need something different in the /etc/sane.d/net.conf
> which at the instant looks like this:
> =================
> # This is the net backend config file.
> ## net backend options
> # Timeout for the initial connection to saned. This will prevent the
> backend
> # from blocking for several minutes trying to connect to an unresponsive
> # saned host (network outage, host down, ...). Value in seconds.
> connect_timeout = 10
> ## saned hosts
> # Each line names a host to attach to.
> # If you list "localhost" then your backends can be accessed either
> # directly or through the net backend.  Going through the net backend
> # may be necessary to access devices that need special privileges.
> scanner.coyote.den # this is in my /etc/hosts file defines its ipv4
>                 # address
> localhost
> ==========================================
> and root at coyote:/etc/sane.d# SANE_DEBUG_NET=255 scanimage -L
> [sanei_debug] Setting debug level of net to 255.
> [net] sane_init: authorize != null, version_code != null
> [net] sane_init: SANE net backend version 1.0.14 (AF-indep+IPv6) from
> sane-backends 1.0.22
> [net] sane_init: Client has little endian byte order
> [net] sane_init: searching for config file
> [net] sane_init: connect timeout set to 10 seconds
> [net] net_avahi_browse_callback: CACHE_EXHAUSTED
> [net] [net] net_avahi_browse_callback: ALL_FOR_NOW
> sane_init: trying to add localhost
> [net] add_device: adding backend localhost
> [net] add_device: backend localhost added
> [net] sane_init: done reading config
> [net] sane_init: evaluating environment variable SANE_NET_HOSTS
> [net] sane_init: evaluating environment variable SANE_NET_TIMEOUT
> [net] sane_init: done
> [net] sane_get_devices: local_only = 0
> [net] connect_dev: trying to connect to localhost
> [net] connect_dev: [0] connection succeeded (IPv4)
> [net] connect_dev: sanei_w_init
> [net] connect_dev: net_init (user=gene, local version=1.0.3)
> [net] connect_dev: freeing init reply (status=Success, remote
> version=1.0.3)
> [net] connect_dev: done
> [net] sane_get_devices: got localhost:brother4:bus2;dev1
> [net] sane_get_devices: finished (1 devices)
> p11-kit: invalid config filename, will be ignored in the
> future: /etc/pkcs11/modules/gnome-keyring-module
> device `brother4:bus2;dev1' is a Brother MFC-J6920DW USB scanner
> device `net:localhost:brother4:bus2;dev1' is a Brother MFC-J6920DW USB
> scanner
> [net] sane_exit: exiting
> [net] net_avahi_cleanup: stopping thread
> [net] net_avahi_cleanup: done
> [net] sane_exit: closing dev 0x97518e8, ctl=296
> [net] sane_exit: finished.
> =============================
> running xsane shows both paths, but both are usb paths, and chosing the
> one labeled net:localhost:brother4:bus2;dev1, the last one above, gets
> me an invalid argument error. I think it should do that, so I am now
> wondering if I have an invalid setup for saned.  Its a start anyway.
> This lists responses have been quite valuable, so I am convinced that the
> ethernet connection is doable yet.  Each time someone has suggested
> something, I have learned a bit more, and I get a bit closer.
> So if someone has an idea about saned setup, please speak up.  And I am
> consciously putting most of this back on the list so what I learn is in
> the list archives.
> Thank you all.
> Cheers, Gene Heskett
> --
> "There are four boxes to be used in defense of liberty:
>  soap, ballot, jury, and ammo. Please use in that order."
> -Ed Howdershelt (Author)
> Genes Web page <http://geneslinuxbox.net:6309/gene>
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

"well, I stand up next to a mountain- and I chop it down with the edge
of my hand"

More information about the sane-devel mailing list