[sane-devel] microtek2 lineart threshold problem

Tom Canavan tmscanavan at centurytel.net
Thu Nov 3 18:28:32 UTC 2016

I am a new member and this is my first post.  I wanted to post here before 
filing a bug report to make sure I am not doing something wrong.

I am having trouble using the scanimage command with the microtek2 backend 
trying to control a Microtek V6USL.

The problem is with the "--threshold" option in Lineart mode. I need to be 
able to control the threshold because with some scans the automatic setting of 
the threshold does not work very well when scanning documents that are printed 
over colored backgrounds.  And I need to do it via command line because I am 
writing a dialog script using Yad dialogs.

I know the scanner Lineart threshold can be controlled, because I can do it 
with xsane and it works well.

Here is my /etc/saned/microtek2.conf:
option dump 1
#option strip-height 14.0
option no-backtrack-option on
option lightlid-35 on
option toggle-lamp on
option lineart-autoadjust on
option backend-calibration on
#option colorbalance-adjust on
#scsi * * Scanner

When I try to run a command to scan a document such as:

scanimage -d microtek2:/dev/sg5 -x 250 -y 20 --resolution 200 --threshold 105 
--mode Lineart --format=tiff > $HOME/faxproject/scans/image.tif

I get an error message:  scanimage: attempted to set inactive option threshold

When I run scanimage -A it says that option is indeed inactive.  So I tried 
putting the line:

option threshold on

in my /etc/saned/microtek2.conf file.
That did not work either.

I then tried putting that line in and also turning off the option lineart-
autoadjust.  That did not work either.

So I am hoping that someone with more knowledge that I can tell me whether 
this is a bug or not, and if not, then show me how to turn the --threshold 
option on for this backend and this scanner.
Any help appreciated.  Thank you.

More information about the sane-devel mailing list