[sane-devel] I/O Errors with hp 7400c

Olaf Meeuwissen paddy-hack at member.fsf.org
Mon Nov 14 11:58:28 UTC 2016

Hi Wolf,

Sorry for the delayed follow-up.

Wolf Drechsel writes:

> Hello Olaf,
> thanks for your attention - greatly appreciated!
>> > I tried
>> > SANE_DEBUG_AVISION=7 scanimage > testfile 2>scannerfehler2.txt
>> > 
>> > and produced the file attached. (After this attempt my machine's
>> > USB bus was blocked again, so a cold reboot was required)
>> Was this on the same machine as where you tried with debian 8.6?  Was
>> the scanner plugged into the same USB port?
> Yes, the all the experimental settings were the same (exept debian
> would not boot on my 1920px monitor, so I attached a 1280px instead).
>> I've looked at the log and it seems that the scanner doesn't reply.
>> At line 1109, it says:
>>  [avision] No data arrived.
>> This could be indicative of a USB3 issue, something Simon Matter
>> already mentioned.  To get a better picture of what's going on at the
>> USB level, could you provide a compressed log made with:
>>  SANE_DEBUG_AVISION=8 SANE_DEBUG_SANEI_USB=5 scanimage > testfile
> I made two attempts - on the first (files with index digit 3) the scan
> was completed properly (result not included), I could do a second one
> (files with index digit 4) which stopped after a fraction of the page.

The 4scanfehler.txt log says:

  [sanei_usb] sanei_usb_read_bulk: trying to read 61054 bytes
  [sanei_usb] sanei_usb_read_bulk: read failed: No such device (it may have been disconnected)
  [avision] read 0 bytes
  [avision] No data arrived.

Looks like a USB issue to me.  I cannot help you any further with that.

The mailing list archives have a number of posts on USB3 issues.  There
is no definite answer of what is wrong, AFAIK.  It is *likely* to be a
kernel issue but there is a somewhat remote possibility that tweaks in
SANE's libusb wrapper may be interfering (depending on the kernel
version) as well.

If at all possible, use the device via USB2.0, by blacklisting the xhci
kernel modules for example.  If not, you may try more recent kernel
image versions or file a bug report against the relevant Ubuntu kernel

Sorry I cannot be of more help,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list