[sane-devel] Canon TS8050 not working correctly

Martin Gubser martin.gu at intergga.ch
Tue Aug 1 22:13:37 UTC 2017


I installed my new Canon TS8050 on Ubuntu 16.4 LTS with the PPA 

The scanner is connected by USB. It is correctly detected. The command
SANE_DEBUG_BJNP=4 scanimage -L 2>log
detects the scanner as well.

The command scanimage -T passes all tests.

A first pre-scan with XSane works, but afterward the scanner does not 
respond any more. The display says “scanning”.
A scan without a pre-scan results in the same error.
Simple Scan produces this same error on the first scan.

SANE_DEBUG_PIXMA=11 xsane &> pixma.log
pixma is compiled with pthread support.
[pixma] pixma version 0.17.42
[pixma] pixma_collect_devices() found Canon PIXMA TS8000 Series at 
[pixma] pixma_find_scanners() found 1 devices
[pixma] pixma_collect_devices() found Canon PIXMA TS8000 Series at 
[pixma] pixma_open(): Canon PIXMA TS8000 Series
[pixma] *mp150_open***** This is a generation 5 scanner.  *****
[pixma] INTR T=5.782 len=32
[pixma]  00000000:00 00 00 01 00 00 00 00  00 00 00 00 00 00 00 00
[pixma]  00000010:00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[pixma] WARNING:send_time() disabled!
[pixma] pixma_scan(): start
[pixma]   line_size=3828 image_size=6714312 channels=3 depth=8
[pixma]   dpi=150x150 offset=(0,0) dimension=1276x1754
[pixma]   gamma_table=0x56123178b848 source=0
[pixma]   threshold=127 threshold_curve=0
[pixma]   adf-wait=0
[pixma]   ADF page count: 0
[pixma] OUT  T=24.435 len=288
<?xml version="1.0" encoding="utf-8" ?><cmd 
[pixma] XML response back from scanner:
<?xml version="1.0" encoding="utf-8" ?>
<cmd xmlns:ivec="http://www.canon.com/ns/cmd/2008/07/common/">
<ivec:param_set servicetype="scan">
[pixma] pixma_scan() failed EPROTO
[pixma] Reader task terminated: EPROTO
[pixma] Setting non-blocking mode
[pixma] read_image():reader task closed the pipe:0 bytes received, 
6714312 bytes expected
[pixma] pixma_close(): Canon PIXMA TS8000 Series

If it helps I could analyze the communication in a Windows-system. Do 
you know a good and safe analyzer? I had used USB-lyzer some years ago 
and can’t use the new version any more without buying it.

Any help is appreciated

More information about the sane-devel mailing list